no ssh login possible

Discussion in 'macOS' started by windfall4crum, Jan 5, 2011.

  1. windfall4crum macrumors newbie

    Joined:
    Jan 5, 2011
    #1
    Hi,

    I hope anybody can help. After hours of reading forums and many tries, I don't know what else I can do.
    I have OS X 10.4.11 and it is not possible to login via ssh, neither from an other machine nor from localhost regardless of username.
    "Permission denied, please try again."
    In secure.log:
    "Jan 3 11:36:45 mac-g5 sshd[444]: Failed password for testuser from ::1 port 49287 ssh2"
    The password was correct because it was trivial.
    ssh -vvv didn't show any suspicious fact.

    The very strange thing about this is a few days ago, it was possible to login and sometimes not. Meanwhile login fails everytime.
    If I configure PubkeyAuthentication, it is possible to login.
    I had copied the sshd_config from another Mac with OS X 10.4.11 on which ssh works fine - no success.
    I suspect that something is wrong with pam, but I have no idea what.

    thanking you in anticipation
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Perhaps there is something in the verbose output that you failed to see. Please paste in the ssh -vvv output (and then wrap it in
    Code:
     tags using the # symbol available in this editor) and post.
     
  3. windfall4crum thread starter macrumors newbie

    Joined:
    Jan 5, 2011
    #3
    Oh please excuse the delay, but I was on vacation.


    Code:
    mac-g5:~ testuser$ ssh -vvv testuser@localhost
    OpenSSH_4.3p2-FC-4.3p2-4.12.fc5, OpenSSL 0.9.7l 28 Sep 2006
    debug1: Reading configuration data /etc//ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to localhost [::1] port 22.
    debug1: Connection established.
    debug1: identity file /Users/testuser/.ssh/identity type -1
    debug1: identity file /Users/testuser/.ssh/id_rsa type 1
    debug1: identity file /Users/testuser/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version p2-FC-4.3
    debug1: no match: p2-FC-4.3
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-p2-FC-4.3
    debug2: fd 3 setting O_NONBLOCK
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: mac_setup: found hmac-md5
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug2: mac_setup: found hmac-md5
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug2: dh_gen_key: priv key bits set: 130/256
    debug2: bits set: 523/1024
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug3: check_host_in_hostfile: filename /Users/testuser/.ssh/known_hosts
    debug3: check_host_in_hostfile: match line 3
    debug1: Host 'localhost' is known and matches the RSA host key.
    debug1: Found key in /Users/testuser/.ssh/known_hosts:3
    debug2: bits set: 518/1024
    debug1: ssh_rsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: /Users/testuser/.ssh/identity (0x0)
    debug2: key: /Users/testuser/.ssh/id_rsa (0x3002c0)
    debug2: key: /Users/testuser/.ssh/id_dsa (0x0)
    debug1: Authentications that can continue: password,keyboard-interactive
    debug3: start over, passed a different list password,keyboard-interactive
    debug3: preferred publickey,keyboard-interactive,password
    debug3: authmethod_lookup keyboard-interactive
    debug3: remaining preferred: password
    debug3: authmethod_is_enabled keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug2: userauth_kbdint
    debug2: we sent a keyboard-interactive packet, wait for reply
    debug1: Authentications that can continue: password,keyboard-interactive
    debug3: userauth_kbdint: disable: no info_req_seen
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup password
    debug3: remaining preferred: 
    debug3: authmethod_is_enabled password
    debug1: Next authentication method: password
    testuser@localhost's password: 
    debug3: packet_send2: adding 64 (len 51 padlen 13 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: Authentications that can continue: password,keyboard-interactive
    Permission denied, please try again.
    testuser@localhost's password: 
    debug3: packet_send2: adding 64 (len 51 padlen 13 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: Authentications that can continue: password,keyboard-interactive
    Permission denied, please try again.
    testuser@localhost's password: 
    debug3: packet_send2: adding 64 (len 51 padlen 13 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: Authentications that can continue: password,keyboard-interactive
    debug2: we did not send a packet, disable method
    debug1: No more authentication methods to try.
    Permission denied (password,keyboard-interactive).
     

Share This Page