No startup after having applied all known (by myself) recovery steps

Discussion in 'MacBook Pro' started by Phbardon, Feb 7, 2014.

  1. Phbardon, Feb 7, 2014
    Last edited: Feb 7, 2014

    Phbardon macrumors newbie

    Joined:
    Feb 7, 2014
    #1
    Traditional recovery steps

    After a forced startup due to a wifi connection issue, the startup stays stuck with a grey screen, Apple logo and turning spinning indicator.
    Then I tried all the following solutions:

    1. Startup in Safe mode: failed
    2. Reset the NVRAM: failed
    3. Checking disk and files with the disk utility of the recovery disk: failed. The disk check was successful and the permissions check revealed some inconsistencies but all have been repaired successfully. Startup on the recovery disk was successful.

    Using Single User startup mode

    Then I started in Single User Mode and followed some guidelines found on Apple pages and various forums.

    1. I reach a #root prompt after

      Code:
      hfs: mounted Macintosh HD on device root_device
              XPCM: registered
              Root device is mounted read-only
      With an alternative suggested between modifying files and continue booting process.
    2. I applied /sbin/fsck_hfs -fy. It finished with
      Code:
      ** The volume Macintosh HD seems to be OK ** and
              ***** The volume was modified *****
    3. I applied /sbin/mount -uv /. It finished with

      Code:
      /dev/disk0s2 on / (hfs. local. journaled)
    4. I applied

      Code:
       launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist.
      It answered

      Code:
      Couldn't stat <plist> No such file or directory. Nothing found to load

    Using dscl(1)

    I read somewhere that the previous error message could be ignored in some situation, but it was impossible for me to determine if it was the cas here. I went into dscl(1) as the issue seemed to come from Open Directories. I stayed in the interactive mode as I'm not expert to take the risk of modifying the files and I was not sure of which files to check.

    1. The answer was the same than the previous error message indicated above: "nothing found to load"
    2. A ls command answers

      Code:
      ls: DS error: eServer error; <dscl_cmd> DS Error: -14910 (eServer error;)
    3. I exited the dscl interactive mode to come back at the #root prompt.

    Trying to look at plist content

    1. Through the command line I changed the current directory to look at files in /System/Library/LaunchDaemons. All files are there, with dates, size and permissions.
    2. Some things surprised me. When asking a simple cd not followed by options the return is -sh: -cd: HOME not set. Maybe this is due to the Single User startup mode? The other one is that when I ask cd .. whatever could be the current directory position in the tree I get -sh: -cd: No such file or directory
    3. I then tried to open a plist to check its content with plutil -convert xml1 <file name> as I was in the LaunchDaemons directory. I first tried with another file, like com.apple.newsyslog.plist. It returns "file doesn't not exists or is not readable or is not a regular file". The same answer is returned for the opendirectoryd.plist file. Files of this directory are all date as of Sep 23, probably the date where the system was installed when I bought the MBP, the size of opendirectoryd.plist file is 698 ko and authorisations are -rw-r--r--
    4. I tried also to open one of my files in the user directories as this error message was maybe due that they were system files. But I had the same answer with a plist I built myself and I was sure to be valid as it's used by XCode in my developments.

    I'm now stuck there ignoring what could be the next step. I would like to avoid re-installing the system. I feel that it's like the startup is unable to find an entry point in the directories even if the command line finds files traditionally. But it's just an assumption. If its true, is thee a way to make him find the files?

    Thanks for your help.
    MacBook Pro (Retina, 13-inch, Late 2013), OS X Mavericks (10.9.1)
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    There's an immediate and easy solution to "I can't boot!" problems such as yours.

    That is:
    Connect your cloned backup drive, and boot from that instead.

    Barring a hardware failure with the Mac, works every time.

    I know this probably won't help you right now.
    But go forward into the future, and learn!
     
  3. Phbardon thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #3
    Startup with clone recovery disk

    @Fishrrman

    I have already started up with the internal recovery disk, and it was successful. It's one of the initial steps recommended by Apple and it allowed me to scan disk and confirm that there are no issues with disk and no issues remaining with permissions. But it does not solve the issue like you said!

    To update initial post, if it can help understanding, I also get another computer (MacBook Air) to use the MBP in target mode. I checked that the plist files in /LaunchDaemons are there and valid for those which I checked.
     

Share This Page