No startup and weird message

Discussion in 'macOS' started by MissMax, Aug 21, 2006.

  1. MissMax macrumors newbie


    Aug 21, 2006
    I turned on my ibook G4 (mac os x 10.3) and instead of it going to the login screen - the screen blacks out with a single line of text on the top. The text reads: -sh-2.05b#. Can anyone help.
  2. bankshot macrumors 65816


    Jan 23, 2003
    Southern California
    That's the command prompt for single-user mode. Normally the only way to get into this mode is by holding Cmd-S during startup. The fact that it dropped you to a command prompt during normal startup probably means something fairly fundamental failed during the boot process. Since there's nothing else on the screen, it's kind of hard to tell what it might be.

    A couple of things to try:

    • Type exit when you see this. Does the machine resume a normal startup then?
    • If not, try rebooting (if you still have the prompt, type reboot otherwise just do a hard power reset) and hold down Cmd-V while the computer boots. Do you see more messages on the screen this time? If so, there may be a clue buried in there.
    • Regardless of the above, you can type tail -40 /var/log/system.log and get the most recent system log messages. Something in there might indicate what failed.
    • If all else fails, get out your Panther install discs and do an Archive & Install. This will move the current (non-working) system files to the side and reinstall a fresh system while keeping your apps and user data. Note that if you have some large commercial apps like Photoshop installed, you may need to reinstall them after this. I normally only do this as a desperate last resort... if you can fix it without doing this, you may be better off.

    Hope this helps. If you get any results from the first two above, I'll be happy to try to interpret. Though there's still a good chance that it'll need the reinstall.
  3. MissMax thread starter macrumors newbie


    Aug 21, 2006

    After Option 1: [typing in exit]
    I get

    /etc/rc: /etc/rc: No such file or directory

    After Option 2: [typing in reboot and holding Cmd V]
    I get

    standard timeslicing quantum is 10000 us
    vm_page_bootstrap: 61401 free pages
    mig_table_max_displ = 68
    IOKit Component Version 7.9:
    Wed Mar 30 20:07:52 PST 2005; root(rcbuilder): RELEASE_PPC/iokit/RELEASE
    84 prelinked modules
    Copyright © 1982, 1986, 1989, 1991, 1993

    using 655 buffer headers and 655 cluster IO buffer headers
    Local FireWire GUID = 0xa95ff:0xfeb3af2e
    ADB present: 8c
    Security auditing present
    From path: “/pci@f4000000/ata-6@D/@0;9,\mach_kernel”, Waiting on <dict ID = “0”><key>IOPathMatch</key><string ID=”1”>IODeviceTree:/pci@f4000000/ata-6@D/@0:9</string></dict>
    Got boot device = IOService:/MacRISC2PE/pci@f4000000/AppleMacRiscPCI/ata-6@D/AppleKauaiATA/ATADeviceNub@0/IOATABLockStorageDrive
    BSD root: disk0s9, major 14, minor 9
    jnl:journal start/end pointers reset! (jnl 0x100edc4; s 0x314600 e 0x314600
    Aug 21 21:22:16 mach_init[2]: Started with uid=0 audit-uid=-1
    /etc/rc.boot:/etc/rc.boot:No such file or directory

    After typing Option 3 typing [tail -40 /var/log/system.log]
    I get “No such file or directory”

    Soooo...I really don't even know what this stuff means...any interpretation will be really appreciated.
  4. bankshot macrumors 65816


    Jan 23, 2003
    Southern California
    Wow, not good. There are a couple of things this could mean, but probably none of them good.

    All of the "no such file or directory" messages mean that critical system files are nowhere to be found on your disk. The "journal start/end pointers reset!" is also troubling because it could indicate a disk error of some sort. At best, it looks like the filesystem on your disk got royally screwed up. If you're lucky, perhaps it can be repaired, but I'm not too hopeful. At worst, your disk may be physically going bad, in which case it would need to be replaced ASAP.

    A few more things to try:

    • Type fsck -y at the -sh-2.05b# prompt. This will attempt to repair the filesystem. If it's successful, then you should be able to reboot afterwards (type reboot when the -sh-2.05b# prompt comes back) and all will be well. But like I said, I don't hold out much hope for this outcome.
    • If that doesn't help, I'm very curious to know what files still exist on the disk. Some critical system files are gone, but yet there are enough files there to boot into the prompt. Type ls -l / at the -sh-2.05b# prompt and see what files/folders it lists.

    Barring any further insight from the results of the ls command, I would go ahead and try the Archive & Install option from the previous message. If you have access to another Mac, you can try to back up whatever is still there before doing the reinstall (though in theory the Archive & Install will preserve your data files, but who knows what it will do if the filesystem is messed up anyway). To do so, get yourself a Firewire cable, boot the iBook and hold down the T key until a firewire logo starts bouncing around the screen. Then hook it up to the other Mac and it will show up as an external drive. You can (hopefully) copy some files over.

    If the Archive & Install also fails, it's probably time to throw in the towel and assume the disk is physically bad. It'll need to be replaced.

    Anyway I hope this helps!
  5. MissMax thread starter macrumors newbie


    Aug 21, 2006
    After typing fsck -y
    I get at the end:

    Volume check failed
    (that can't be a good sign)

    After ls -l /
    I get (I left out the date and times)

    total 48367
    -rw-rw-rw- 1 root admin 15364 .DS_Store
    d-wx-wx-wt 3 root admin 102 .Trashes
    -r--r--r-- 1 root wheel 156 hidden
    -rw------- 1 root admin 262144 .hotfiles.btree
    dr-xr-xr-x 2 root wheel 68 .vol
    drwxrwxr-x 45 root admin 1530 Applications
    drwxrwxr-x 16 root admin 544 Applications (Mac OS 9)
    -rw-r--r-- 1 root admin 226816 Desktop DB
    -rw-r--r-- 1 root admin 1755666 Desktop DF
    drwxrwxr-x 2 root admin 68 Desktop Folder
    drwxrwxr-x 2 501 admin 68 Documents
    drwxrwxr-x 21 501 admin 714 Image Mixer
    -rw-rw-r-- 1 503 admin 3622905 Internet Explorer
    drwxrwxr-x 40 root admin 1360 Library
    -rw-rw-rw- 1 root admin 6373624 NAVMac800QSFile
    drwxr-xr-x 6 501 admin 204 Netscape Base Install Folder
    drwxr-xr-x 5 root wheel 170 Network
    -rw-rw-r-- 1 503 admin 4054267 Outlook Express
    drwxr-xr-x 4 root wheel 136 System
    drwxrwxr-x 37 root admin 1258 System Folder
    drwxr-xr-x 2 501 admin 68 Temporary Items
    drwxr-xr-x 2 501 admin 68 The VolumeSettingsFolder
    -rw-r--r-- 1 root admin 0 User Guides and Information
    drwxrwxr-t 9 root admin 306 Users
    drwxrwxrt 8 root admin 272 Volumes
    drwxr-xr-x 4 root admin 136 automount
    drwxr-xr-x 35 root wheel 1190 bin
    drwxrwxr-t 2 root admin 68 cores
    dr-xr-xr-x 3 root wheel 3840 dev
    lrwxr-xr-x 1 root admin 11 etc -> private/etc
    lrwxr-xr-x 1 root admin 9 mach -> /mach.sym
    -r--r--r-- 1 root admin 5471184 mach.sym
    -rw-r--r-- 1 root wheel 3872560 mach_kernel
    drwxr-xr-x 5 root wheel 170 private
    drwxr-xr-x 62 root wheel 2108 sbin
    lrwxr-xr-x 1 root admin 11 tmp -> private/tmp
    drwxr-xr-x 10 root wheel 340 usr
    lrwxr-xr-x 1 root admin 11 var -> private/var

    What I really want to keep from my laptop besides all the documents is my music from iTunes. Can you tell me from this if it is still there? If not there's really no real urge to restore anything else. Thanks again - you're such a help.
  6. funkychunkz macrumors 6502a


    Jun 1, 2005
    Ottawa, Canada
    Since your computer should be able to still boot into target disk mode (if your firmware remains unaffected), and have another computer available (preferably a mac) you can salvage your data and re-install. Alternatively you can copy your system files over (if the computers are running the same os).

    You'll need to copy at least the rc file in /private/etc/ which is responsable for booting your system, and you'll need admin priviledges to do so. Heck, just replace /private and reboot into single user to run fsck -fy. There are some files that shouldn't be copied, because of hardware differences, but I'll need to get to you on that. Im sorta busy...

    EDIT: OK, found them

    delete before rebooting:

    /var/vm/swap (all of them that start with that)

    EDIT 2: I should probably say that the rc.boot is responsable for handling the boot of multi user mode (aka not single user). Booting from another source should still work because it's files are still intact. Diskwarrior can't help because the directory rc.boot is missing. It can't repalce it. You need to reaplace it yourself or re-install. If you don't have another mac you can try recovery software, or booting from an external HDD. If in fact the directory exists but it cannot be found because of the catalog file being messed up/corrupt, I remember there being a command to attempt to undelete a file.
  7. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    I don't really have any advice to offer, but I needed to post in this thread to thank MissMax for being an absolute model of what the regulars here at MR like to see from people who need help. You follow instructions explicitly and provide great feedback with complete results from your efforts.

    Dealing with posters like this is so much more enjoyable than those who say "My MAC doesn't work!" and then force you to pull teeth to figure out what's going on. Thank you for being so clear in your posts and for being so cooperative! It sounds like you unfortunately have some serious problems, but the folks here will do (and are doing) their best to get you patched up.
  8. MissMax thread starter macrumors newbie


    Aug 21, 2006
    Thanks...:( efforts seem to be in vain though
  9. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    Sorry to hear it. Were you able to try Disk Warrior? Highly recommended, when nothing else works.
  10. bankshot macrumors 65816


    Jan 23, 2003
    Southern California
    Ugh, a little too busy to reply the last 2 days. Hopefully things got worked out? ;)

    I would echo IJ Reilly's recommendation to try Disk Warrior. I can't count the number of times it has saved me when Apple's filesystem checker gave up. Well worth the investment. I should have mentioned it when I talked about the fsck command. If the problem is merely corruption but not bad hardware, Disk Warrior will almost certainly fix it.

    If that doesn't work, I'd just reiterate the recommendation to use another Mac (if you can) to access the iBook in target disk mode and get your files off before reinstalling OS X. Your music files will be in Users -> yourname -> Music. Also, make a backup of Users -> Shared if you have any music purchased from the iTunes Music Store. That's where your authorization is kept. You can then restore it after reinstalling.

    Good luck!
  11. MissMax thread starter macrumors newbie


    Aug 21, 2006
    Thanks everyone. I'll let you all know how it all worked out. :)

Share This Page