No success while adding a Ipv6 Link local address to OSX 10.8.5

Discussion in 'OS X Mountain Lion (10.8)' started by hrksh, Jul 21, 2014.

  1. hrksh macrumors newbie

    Joined:
    Jul 21, 2014
    #1
    Hi All,
    I need a quick help.
    I was trying to add a IPv6 Link local address using Ifconfig

    Code:
    sudo ifconfig en0 inet6 fe80::204:a3ff:fe12:13b4 add
    
    
    and the result is
    Code:
    ifconfig: ioctl(SIOCGIFAFLAG_IN6): Can't assign requested address
    
    again I tried using
    Code:
    networksetup -setv6manual Ethernet fe80::204:a3ff:fe12:13b4 64 fe80::21f:d0ff:fe40:8bbd
    
    but interface en0 doesn't show any Ipv6 link local address when I do ifconfig en0.

    result -

    Code:
    $ ifconfig en0
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    	options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
    	ether 40:6c:8f:05:5d:f0 
    	inet 169.254.138.147 netmask 0xffff0000 broadcast 169.254.255.255
    	media: autoselect (100baseTX <full-duplex>)
    	status: active
    
    please help me quickly.
     
  2. hrksh thread starter macrumors newbie

    Joined:
    Jul 21, 2014
    #2
    One more input on this -
    I tried ping6 -c 5 ::1 and there are responses.

    Code:
    $ ping6 -c 5 ::1
    PING6(56=40+8+8 bytes) ::1 --> ::1
    16 bytes from ::1, icmp_seq=0 hlim=64 time=0.136 ms
    16 bytes from ::1, icmp_seq=1 hlim=64 time=0.283 ms
    16 bytes from ::1, icmp_seq=2 hlim=64 time=0.287 ms
    16 bytes from ::1, icmp_seq=3 hlim=64 time=0.285 ms
    16 bytes from ::1, icmp_seq=4 hlim=64 time=0.275 ms
    
    
    But system preference -> network -> status shows ,
    Ethernet is connected to the link local address "fe80::204:a3ff:fe12:13b4".

    but when i do ping6 from a peer machine which is connected to the MAC OS device, no response from the MAC OS. I checked from wire shark.
     
  3. hrksh thread starter macrumors newbie

    Joined:
    Jul 21, 2014
    #3
    Hi All,
    Please help me to solve this issue.
    few more inputs -
    Code:
    microchips-macbook-pro:/ microchipidc$ netstat -rnf inet6
    Routing tables
    
    Internet6:
    Destination                             Gateway                         Flags         Netif Expire
    default                                 fe80::21f:d0ff:fe40:8bbd%en0    UGc             en0
    ::1                                     link#1                          UHL             lo0
    2001:db8:ffff:2::/64                    link#4                          UC              en0
    2001:db8:ffff:2:426c:8fff:fe05:5df0     40:6c:8f:5:5d:f0                UHL             lo0
    2001:db8:ffff:2:c53c:f3f3:aa63:e3f5     40:6c:8f:5:5d:f0                UHL             lo0
    fe80::/64                               link#4                          UC              en0
    fe80::204:a3ff:fe12:13b4                40:6c:8f:5:5d:f0                UHL             lo0
    fe80::%lo0/64                           fe80::1%lo0                     UcI             lo0
    fe80::1%lo0                             link#1                          UHLI            lo0
    fe80::%en0/64                           link#4                          UCI             en0
    fe80::204:a3ff:fe12:13b4%en0            link#4                          UHLWIi          en0
    fe80::21f:d0ff:fe40:8bbd%en0            0:1f:d0:40:8b:bd                UHLWIir         en0
    fe80::426c:8fff:fe05:5df0%en0           40:6c:8f:5:5d:f0                UHLI            lo0
    ff01::%lo0/32                           fe80::1%lo0                     UmCI            lo0
    ff01::%en0/32                           link#4                          UmCI            en0
    ff02::%lo0/32                           fe80::1%lo0                     UmCI            lo0
    ff02::%en0/32                           link#4                          UmCI            en0
    microchips-macbook-pro:/ microchipidc$ 
    
    
    
    Mac laptop is connected point to point with another IPv6 router machine.
    While doing ping from router to the mac laptop , there is only Neighbor solicitation message received from the router and no response is being sent from the Mac laptop for the IPv6 address

    fe80::204:a3ff:fe12:13b4
     

Share This Page