No system App will launch

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by ozarkmatt, Feb 22, 2005.

  1. ozarkmatt macrumors newbie

    Feb 22, 2005
    I searched, but haven't seen this one. Everythign was fine last night when I shut down, but this morning, nothing will work - if it's an application that comes from OS x. Mail, safari, calculator, address book, etc. i try to launch the app, the little icon bounces twice and the black triangle appears. However, no window, it's like the application never finishes opening.
    The program is on though, becasue I have to "force quit" it when I tried to restart.
    I safe booted and no change.
    I tried to run disc utility to repair permissions, but I guess it's a system app too, for it will not open. I tried to reinstall the last system update, but the installer program will not launch either.
    Any ideas? I installed 10.3.8 at the beginning of the month when it came out and have had no problems until this morning.
    This one is frustrating.
  2. emw macrumors G4


    Aug 2, 2004
    Have you tried booting from the install CD that came with your Mac? You could then run a repair disk/repair permissions from the Disk Utility application on that CD.
  3. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    When all the "System apps" crash the way you describe there's also the chance that it's Font realted. If one of the System Fonts (like Helvetica) is missing or corrupt then this affects Apple's own programs. My girlfriend had this problem after replacing a couple of System Fonts (as far as i remember: Times, Helvetica and a couple of others) and Safari, Mail, iCal, etc. stopped working (in the exact same way as you describe). Unluckily also FontBook refused to work, but I transferred my System Fonts over to her machine and everything was fine again...

    If fixing permissions etc. doesn't work you could look at this approach...
  4. ozarkmatt thread starter macrumors newbie

    Feb 22, 2005
    Yes I am afraid it's font related, one of my co workers said he had a font problem that stopped Safari.
    Permissions repair didn't work (although all it repaired was font files) I guess it's manual font replacement time.
    But I don't understand why, when it worked fine last night.
  5. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Possibly because the font was loaded into memory, and then when you shutdown/restarted, that font was gone..
  6. ozarkmatt thread starter macrumors newbie

    Feb 22, 2005
    Can anybody give me a guide of what just the system fonts are?
    Helvetica, Times are obvious. Is the dingbats font part of it? Arial?
  7. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    Are the fonts just missing from your User/Library/Fonts folder or from the System/Library/Fonts folder?

    If you set up a new user, do the apps open? If so, you might be able to copy the missing font from the System Font folder to your User folder.
  8. ozarkmatt thread starter macrumors newbie

    Feb 22, 2005
    Well, I logged out and logged back in as a differrent user. Safari and mail opened fine. So, I'm thinking the problem is with a font in my user library. Log out and back on with my main user ID and everything worked fine. I did not move a file.
    Weird huh?
    I wonder about the what happened and why, but I guess it's all well now. (Hopefully - does anybody have a feeling I am headed for a serious disaster?)

    Thanks all for helping this newbie . . . . .

Share This Page