No time-stamps over imported clips in iMovie 10?

Discussion in 'Digital Video' started by cairene2011, Nov 10, 2014.

  1. cairene2011 Guest

    Joined:
    Dec 17, 2013
    #1
    First and foremost: Please forgive me for the very untechnical and long-winded description of my problem, but I'm not very literate when it comes to video editing and on top of that my OS is in German, so I'm not sure of the exact English names of the menus concerned. :eek:

    ---------------------------

    I've been using iMovie since the version that came with Snow Leopard and had the following workflow, which was the most time-efficient for me:

    1. I'd review the raw video files in Quicktime without much pausing while writing down on a notepad the time stamps of the scenes I was going to cut. Eg "Clip 1, 06:34-07:12, CUT"
    2. Then I'd import the footage into iMovie and hover my cursor over the respective clips until the correct time stamp appeared, dragging only the required frames into the project timeline and cutting them according to my notes without reviewing again until the final check.

    That was super-fast for me and it saved CPU, because my computer deals a lot better with replays in Quicktime than in the tiny replay-window within iMovie.

    Now, in iMovie 10 I can't seem to find these time stamps. I can hover my cursor over the imported original clip as long as I want, it doesn't tell me where exactly I am at. Only the selected footage down in the project timeline shows time stamps, but they don't correspond to the time stamps of the original clip either. If I dragged down 2 frames from the same original clip A, both frames will now start at 00:00 instead of their time-stamp in the original clip ... rendering my notepad pretty useless.

    Now I have to work painfully slow, first dragging the entire raw footage into the project timeline at once, watching every clip as I go along editing out the parts I don't want. My computer starts boiling, the software freezing, because of course it's a lot more work to drag the entire 20 minute video in the project timeline and edit going along watching. Previously, I would handpick the raw clips that were going into the project timeline according to my handwritten notes (eg "06:23 - 08:05"), so the computer wasn't required to work with the entire footage at once.

    But even if I manage to import the entire 20 minute video into the project timeline and start editing, the problems don't stop. Often I want to cut very precisely, filler words like "ahem" without cutting into the start of the following word... which is pretty tricky without the time stamps that tell you the concerned second.

    I tried to get used to it, but after almost 3 weeks I have not managed to complete a single project. Often I take a few hours to edit watching as I go along only to realise in the end that I could have done something in the middle differently, requiring me to watch back the entire project to even locate that moment, because no time stamp will guide me there.
    In the old iMovie I could simply locate any scene by its original time stamp in the imported raw footage and then right-click "show in project" ... and voilà I'd be there in a split-second.

    I'm super-confused, either I haven't managed to activate most of the program's features yet or its redesign has been slimmed down from the predecessor. I also tried to fire up iMovie 9 again, but nothing happens when I click the icon, so maybe it's not compatible with Yosemite anymore? Maybe it only needs a clean install, but where do I get the installer from? There is only iMovie 10 in the Mac App Store.

    I'm now considering to buy FCP, although I'm sure it's way too professional for my needs/skills, but without these time stamps I'm really quite handicapped. Before making the purchase, I'd however need to know if these time stamps exist at all in FCP?


    I sincerely apologize for the untechnical and clumsy description, as you can tell I'm by no means a professional. Maybe a kind soul can help me though activating the time stamp feature in iMovie 10, getting iMovie 9 to work on Yosemite or tell me if FCP has got these time stamps! :)


    Macbook Air 2011, 1.8 GHz i7, 4GB
    Yosemite 10.10
    iMovie 10.0.6
     
  2. daybreak macrumors 6502a

    Joined:
    Sep 4, 2009
    #2
    You are doing yourself a lot of work for nothing.Just load your footage and then select what you wish to import. FCP-X will be much better for you.;)
     

Share This Page