No users after normal startup

Discussion in 'iMac' started by Mariaw05, Apr 21, 2011.

  1. Mariaw05 macrumors newbie

    Joined:
    Apr 21, 2011
    #1
    Hi--

    I am usually able to figure out how to fix my computer issues, but this one has stumped me.

    My iMac has been running REALLY slow lately. And occasionally, it would say that I don't have enough room to install something (when I actually have 32 GB, and what I wanted to install was less than 1 GB). Yesterday, Safari stopped responding and I had to force quit it. I restarted my computer, and it gave me a generic screen with no users in the upper right corner. Only a magnifying glass--no time, no nothing. The mouse would move, but nothing would open or drop down when I clicked. I forced a shutdown by pushing the button in the back, and restarted in safe mode.

    In safe mode, I'm able to log in. Safari still locks up after about a minute, but Firefox works fine. When I try to restart in regular mode though, nothing has changed. Here's what I've already done:

    1. Repaired disk permissions in Disk Utility
    2. Verified disk--said everything is ok
    3. Moved the 2 files in the startup folder to the desktop
    4. Deleted the safari cache and .plist file
    5. Reinstalled safari with the newest update

    One of the things I suspect is that I deleted a bunch of files (mostly games) yesterday. I put them in the trash, then emptied the trash to free up more space since everything was running so slow. In the process, I deleted Parallels from the application folder without uninstalling it (didn't realize I needed to at the time). The 2 files in my startup folder were both Parallels files, so I was hoping taking those out would solve my problem. But it has not. I may have inadvertently deleted something else from my Applications folder that I might need, but since I emptied the trash, I don't know what it would be. I know, I know, I should not have emptied the trash....

    Would an Archive and Install help? I am guessing since Safe Mode opens up ok, then it's not the operating system, but rather something in Startup.

    I'm running OS 10.6.6, and have 3GB 667 MGz DDR2 SDRAM.

    Thanks....
     
  2. spcdust, Apr 21, 2011
    Last edited: Apr 21, 2011
  3. Mariaw05 thread starter macrumors newbie

    Joined:
    Apr 21, 2011
    #3
    spcdust,

    I read your reply in my email before you deleted it, and it actually worked! This is what I did:

    1. Rebooted with Install Disk (Snow Leopard).
    2. Selected English for language.
    3. Utilities>Reset Password (on top menu--don't click continue on main install window).
    4. Clicked Admin "Root" account and set a password.
    5. Restarted with hard drive.
    6. Now I had login options in the top right corner, and I selected "Other" to log in as admin/root. Username: root; Password: (what I set)
    7. I tried at this point to go into system preferences and create matching user accounts, but my original ones were already there, and it wouldn't let me duplicate them. So I just went back to the login screen and tried to log into my main account, and viola! Everything worked!

    Thanks so much.
     
  4. spcdust, Apr 21, 2011
    Last edited: Apr 21, 2011

    spcdust macrumors 6502a

    spcdust

    Joined:
    May 6, 2008
    Location:
    London, UK
    #4
    Really glad that helped you out - apologies I deleted my reply but after re-reading your post I thought that you may have deeper rooted issues I and didn't wish to lead you astray in your resolution (also at the time was a little frantic at work so was speed typing in my response). Great you're back on track:):):)
     

Share This Page