no wifi connection with external monitor...help pleaseee

Discussion in 'MacBook Pro' started by mackasha, Aug 24, 2010.

  1. mackasha macrumors newbie

    Joined:
    Aug 24, 2010
    #1
    My problem right now is, when i connect my macbook to my hp external monitor wake the computer up in closed lid mode, my internet connection is lost, and it doesn't come back unless i restart my computer.

    I'm using the new airport express.

    Please, how can i make it so i can connect my external monitor, use it in closed lid mode, and keep my internet connection
    But it work in that scenario with the lid open.

    I'm just trying/wondering how to figure out lid closed while can be connected with the wireless connection.
    thanks a lot!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Using your MBP in clamshell mode with an external display should have zero effect on your WiFi. I do this all the time with an AirPort Express and it works just fine. Rather than restarting, try simply clicking the AirPort icon on your Menu Bar, letting it detect available networks, and see if it doesn't automatically reconnect to your WiFi network. It might take a minute or two, waking from sleep mode.
     
  3. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #3
    Correct me if Im wrong, but is the antenna not in the display top case?:confused:

    Are you a long way from your router?
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    The antenna is in the hinge area, so it shouldn't be affected by clamshell mode.
     
  5. mackasha thread starter macrumors newbie

    Joined:
    Aug 24, 2010
    #5
    yeah, but why after it's connected with my external display the wireless connection is lost when the lid is closed. after than i try to open up the lid with blank screen it's automatically reconnected back to the wireless. it's when the lid closed the wireless hardware signal kind of weak? i'm just a 2nd room and my route is on the study room. without any external display with a normal laptop it work fine. just after the lid closed totally no signal and wireless get lost.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Did you try the suggestion I posted about reconnecting?
     
  7. mackasha thread starter macrumors newbie

    Joined:
    Aug 24, 2010
    #7
    yeah i tried and changed a new router with stronger antenna but it stil not working.. kindly bad for me!
     
  8. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #8
    I think closing the laptop is less ideal for antenna reception since the antenna is in the hinge. If you ran it with the screen open and the external monitor, it should improve wireless reception. Just run it in extended screen mode.
     
  9. mackasha thread starter macrumors newbie

    Joined:
    Aug 24, 2010
    #9
    well.. why some of my friends and other people, their may run a wireless connection while the lid are closed. but mine aint to do that, when i tried closed the lid, and my wireless signal goes weak and off. so I just wonder, it's a hardware problem or something?
     

Share This Page