No window frame aroud xterm and applications using X11

Discussion in 'macOS' started by iota, Oct 9, 2011.

  1. iota macrumors newbie

    Joined:
    Oct 9, 2011
    #1
    Hi everyone,

    when I am using X11 with any applications , I have no more window frame. It means I can't drag, resize or close the window with the GUI.

    I tried to remove and to reinstall X11 with the DVD provided by Apple, but it still doesn't work.

    I'm not sure it's linked, but I have just installed wine on my mac with macport.
    And I noticed this problem just after that.

    The problem is I don't know where to look for, I've been searching all around on the web without find a solution. I think the windows manager is independent from X11, and it can be switched.

    I am new with these notions and with this forum, so sorry if my post is not at the right place.

    Thanks for your help.

    PS : Mac OS 10.6.8
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Yes, you are right. X11 on Mac OS X normally uses the quartz-wm window manager. However, in your case it's gotten detached somehow. This should be fixable if you can find the configuration file that needs editing. Alas, I do not know which one to edit, since I have never seen this problem before on Mac OS X.
     

Share This Page