no Windows Clients show up in Finder (windows 2008 domain)

Discussion in 'macOS' started by iMau, May 24, 2010.

  1. iMau macrumors newbie

    May 24, 2010
    Hi all,

    I have the following problem. I have a Windows 2008 Domain with serveral windows clients and one macbook.

    In Finder i cant see any Windows machines except for a NAS which is not member of my domain.

    When i had a 2003 domain i could see all Windows clients and Server.

    I tried several things but the finder still doesnt show alle Windows clients.
    My macbook has snowleopard 10.6.3.

    I can connect to my server with CMD K smb://servername - but it take ages to connect.

    When i take out one of my Windows Machine out of the Domain it popups in Finder on my Mac.

    I did several GPO changes like:

    Domain Controller Policy Local Policies - Security Options

    Network security: LAN Manager authentication level
    Send LM & NTLM responses

    Minimum session security for NTLM SSP
    Disable Require 128-bit encryption

    But this does not make any difference.

    Anyone any clue?

    thx in advance
  2. uiopgolaz macrumors newbie

    Feb 6, 2011
    I have the exact same problem in my server 2008 r2 domain, tried just about anything and still no solution.

    If anyone could help, I'd really appreciate it.

    thanks in advance :apple:
  3. brandone macrumors member

    Sep 3, 2010
    San Francisco
    Did either of you bind your Mac clients to the domain?
    System ---> Library ---> Core Services ---> Directory Utility

    Let me know if you already have tried this, if you havent, i wrote a process for you to follow.

    Joining Active Directory OS X 10.5 & 10.6
    1a. From the Utilities folder in the Applications folder, open the Directory Utility application.(10.5)
    1b. From the \System\Library\CoreServices, open the Directory Utility application.(10.6)
    2a. Once the application opens and finishes the process of detecting directory servers on the network, click the Show Advanced Settings button. (10.5)
    2b. N/A (10.6)
    3a. When the Advanced Settings appear, click the Services icon. (10.5) 3b. N/A (10.6)
    4. Click the lock to get access to the panel. You will be prompted for credentials. Enter your LOCAL Macintosh username and password, then click OK.
    5. Double-click on the Active Directory line to open the Active Directory configuration.
    6. Click on the Show Advanced Options triangle.
    7. Enter the internal domain name in the Active Directory Domain field.
    8. Change the name of the Mac to a shorter name in the Computer ID field. 9. Turn on the Create mobile account at login checkbox.
    10. Select the Administrative tab.
    11. Turn on the Prefer this domain server checkbox and enter the fully-qualified domain name of the Windows server.
    12. Turn on the Allow administration by checkbox.
    13. Click Bind to join the Macintosh to the domain.
    14. Enter the domain administrator username and password when prompted. The Macintosh will be placed in the Computers container by default. This can be changed in Active Directory later if needed.
    15. Once the join process is complete, you will see both the Active Directory Forest and Active Directory Domain fields populated.
    16. Confirm that the Active Directory checkbox is enabled in Directory Utility and close the application.
    17. Open System Preferences and click the Accounts icon.
    18. Click the lock to make changes and enter the password for the local Mac account.
    19. Click on the Login Options icon in the navigation tree.
    20. Set Automatic Login to Disabled.
    21. Close System Preferences.
    22. Log out of the Mac account by selecting Log Out from the Apple menu. You do not need to restart the Mac to be able to log in with your Active Directory credentials.
    23. When you get the login screen, click Other.
    24. Enter your Active Directory credentials as domainname\username.
    25. You will be prompted to create a mobile account. Click Create Now.
    26. Once login completes, open System Preferences and open the Accounts pane.
    27. Click the lock to make changes.
    28. When you are prompted to enter an administrator credentials, you will need to enter information for the LOCAL Macintosh account.
    29. After you enter the authentication information, turn on the Allow user to administer this computer checkbox.
    30. You will get a message that you need to log out and log back in for the settings to take effect. Click OK.
    31. Log out and log back in with the Active Directory credentials.
    32. Open a new Finder window and select the server name in the Shared section of the navigation tree. All of the shares on the server will appear and can be selected from here.
  4. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    I saw an Apple Discussion that worked for me on Windows 7. It might help you on Server 2008.
  5. uiopgolaz macrumors newbie

    Feb 6, 2011
    I've tried joining it to our 2008 R2 domain and there is no change in visibility.
    All the pcs joined to our domain are invisible, all the others are there.

    strange :confused:
  6. brandone macrumors member

    Sep 3, 2010
    San Francisco
    Are all of your computers on the same subnet? I have experienced problems when using a router to router VPN where IP pool 1 is 10.10.10.x and pool 2 is 10.10.20.x. The mac were unable to see the PC's in that case.
  7. r0k macrumors 68040


    Mar 3, 2008
    Have you tried (in finder) go->connect to server->smb://ip_address (of one of your windows boxes) ? It works for me when one of my linux boxes that is sharing stuff via samba (windows emulation) disappears from finder. I've found that after I connect this way, the servers seem to "stick" and it's easier to find them. If they go away again, I simply use connect to server to bring them back.
  8. uiopgolaz macrumors newbie

    Feb 6, 2011
    All the computers ae on the same subnet 10.11.12.x.
    I've also tried connect to server and its taking tooooooo long to connect, sometimes it freezes the finder... :(

    Thanks guys for the tips anyway ;)

Share This Page