No wireless on 3GS after Jailbreak

Discussion in 'iPhone Tips, Help and Troubleshooting' started by eleven7, Nov 9, 2009.

  1. eleven7 macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #1
    Up until today I have experienced no problems since jailbreaking my 3GS 2 days ago.

    Today I went to go online and realised that I wasn't connected to the household wireless network which I've had no problems with up until now. I double checked the router which is all in order, which it was. Next I checked that I was able to connect to the router using 2 different laptops in the house, which I could. No matter what I do the iphone doesn't pick up any wireless networks at all even when I'm sitting right next to the router??

    I tried inputing the network login details manually Settings>Wireless>Other
    but I get a message saying the network can't be found.

    In place where the wireless signal strength icon usually is on the menu bar, is a circle which I've never seen before but that might just be because I've always used 3G and since Im on holiday overseas, I have switched 3G off.
     
  2. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #2
    This is a known problem with OS 3.1.2 whether JB or Vanilla. Geohot explains on his blog.
     
  3. cscturulo macrumors newbie

    cscturulo

    Joined:
    Jul 18, 2002
    #3
    You have to toggle on and off your network settings, reset them a few times and it should solve the issue.
     
  4. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
    I had a similar problem. Reset network settings didn't work for me. This is what I did to fix it:

    Put phone into DFU mode and restored to 3.1.2

    Ran Blackra1n RC3, tested wifi OK

    Ran Backra1n.app and installed Cydia, tested wifi OK

    Installed OpenSSH and Terminal, tested wifi OK

    Ran Blackra1n again and installed sn0w, tested wifi OK

    Restored from backup, tested wifi OK

    Tested the phone through a few reboot cycles, everything is now fine.


    Because my initial install of 3.1.2 was an update, I assume that something already on the phone caused some kind of wifi firmware problem which was solved through the clean restore. Only other thing is that I normally have wifi switched off, so maybe installing with it off does something funny. That's all I can think of.
     
  5. eleven7 thread starter macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #5
    Thanks for the replies. After reading the numerous related forums about the problem after a 3.1.x update, I used this tip to solve the problem...

    1 - Turn on air plane mode.
    2 - reset network settings.
    3 - turn air plane mode off.
    4 - connect to wifi.


    Worked for me, but not everyone apparently. Hopefully Moi un Mouton tip can solve the problem for the people that the first fix doesn't work for.

    This is pretty major and sounds like it has been around for a while, can't believe Apple hasn't fixed it by now.
     

Share This Page