Non-descript error when installing ML

Discussion in 'Mac Basics and Help' started by j7house, Aug 22, 2014.

  1. j7house macrumors newbie

    Joined:
    Aug 22, 2014
    #1
    Hi all,

    I've been struggling with getting my 2012 21.5" iMac going. It was passed along to me, and so I wanted to do a clean reboot of the OS. I was able to successfully erase and partition the HDD, but when it came time to reinstall ML, I get the following error:

    "An error occurred while preparing the installation. Try running this application again."

    This error pops up after I have selected the target disk.

    As a curious note, the first time I tried, it got about 30% of the way before saying "Unable to download additional components needed...". Every attempt after that has led to the above error.

    Any ideas would be much appreciated!
     
  2. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #2
    Have you tried forcing it to redownload the Internet Recovery image by holding CMD OPT R at boot?
     

Share This Page