Non-Jailbroken Apps Don't Open

Discussion in 'Jailbreaks and iOS Hacks' started by ScootPatoot, Nov 25, 2008.

  1. ScootPatoot macrumors regular

    Joined:
    May 16, 2008
    #1
    So I had this problem with 2.1 Jailbreak where if I opened any app that I downloaded from the App Store, it would show it's Splash Screen but then kick me to the Home Screen.

    This only happens on App's from the App Store. Standard Apps (Contacts, Safari, SMS, Maps, etc.) all were able to open fine. All Jailbroken apps worked fine as well.

    So I figured I'd give the 2.2 Jailbreak a chance. Same thing is happening. Now I noticed that it happened after I installed hacked app's from the App Store and I used SBSettings to change the permissions on the directories (I forget what the name is but it's under Extra in SBSettings).

    Anyone ever experience this and have a resolution. If not I cannot keep my phone jailbroken as I balance my check book using SplashMoney. :eek:
     
  2. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #2
    Check that. I just had to do a restore and rejailbreak my phone. First thing i did was open SplashMoney and it opened fine. I loaded SBSettings and went to More and then Extras and clicked on Fix User Dir Permissions and rebooted. SplashMoney still opens.

    So I'm not sure why it doesn't work sometimes. But I'm hesitant to say it's fixed because it worked fine last night after jailbreaking as well. But when I got into work this morning I tried opening SplashMoney and it acted as described in the first post.

    I think the symptoms may still come back...
     
  3. LastZion macrumors 6502a

    Joined:
    Apr 13, 2006
    #3
    If it comes back, just delete the apps from your phone and re-sync them back on with Itunes, should solve it
     
  4. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #4
    Tried it with the 2.1 jailbreak and it didn't work. Thanks for the suggestion tho. I think maybe my permissions got wacky so if it comes back I'll take a look at those and see.
     
  5. DN7335 macrumors 6502

    Joined:
    Jun 9, 2008
    #5
    Yes I'm guessing its a permissions thing also, are you using the hacked MobileInstallation file with cracked apps?
     
  6. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #6
    Yeah I installed the hacked file. I did figure it out though. I use SwapTunes. When the iTunes library isn't on the same library that I synced the app's with, it will shut down. So I open SwapTunes to switch the library and the app's work.

    Thanks for the help.
     
  7. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #7
    Maybe not

    So I spoke too soon. Swapping libraries does not solve this problem. I've tried opening app's on both libraries and they shut down both times.

    Again, this is only on app store apps that I bought or that were free. Nobody has this problem? :confused:
     
  8. sidneysides macrumors newbie

    Joined:
    Nov 26, 2008
    #8
    Exactly the same happened to me today too. I've deleted all apps from itunes library and synced so they are deleted from the iphone. Then redownloaded them from the ITunes store and am putting them back on one by one. Pain I know, but its working at the moment.
     
  9. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #9
    Yeah. It sucks. It's random too. Right now all of my apps are working. I just rebooted since my last post and they are all working now.

    I've rebooted in the past when this happens and it didn't fix the issue. I'm not sure what the problem is...
     
  10. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #10
    It's something to do with your MobileInstallation file. You've obviously not followed the instructions correctly for how to do it all. Restore your phone and start again.
     
  11. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #11
    Actually that isn't obvious at all, nor correct. I followed instructions step by step, re-reading each step before proceeding.
     
  12. bradenwh macrumors 6502

    Joined:
    Apr 12, 2008
    #12
    Sigh.

    It's an authenticity problem. Make sure you're logged in on the iTunes Store, and sync. If that doesn't fix it, download an app from the iPhone's App Store, and make sure it makes you put in your password. Once that app is downloaded, see if it opens. If it does, the rest should.
    If that doesn't help, I dunno what's wrong. Sorry.
     
  13. amemoryoncelost macrumors 6502

    Joined:
    Jun 14, 2004
    #13
    I'm having the same issues. Going to try a couple of things and then try a restore/quickpwn again and try it out.

    I was having issues with free apps. I redownloaded ebay and it seems to be working as do a few other apps. I dunno, it just stopped working all of a sudden today. I'll post back if I can figure anything out.,
     
  14. sidneysides macrumors newbie

    Joined:
    Nov 26, 2008
    #14
    This has started happening again. Anyone got a solution yet?
     
  15. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #15
    I'm copying a PM that I received from someone who shall remain nameless. This worked for me:
    "
    Hey, didn't want to post in the thread about this because I'm not keen on advertising my patched mobileinstallation.. but, this is what worked for me --

    Delete /private/var/mobile/Library/Caches/com.apple.mobile.installation.plist

    Reboot

    Download a free app in iTunes

    Sync your phone

    You can then delete the free app if you so choose, but you should be able to find something that you may find actually useful.

    Good luck.
    "
     
  16. sidneysides macrumors newbie

    Joined:
    Nov 26, 2008
    #16
    I'm new to this stuff. How do I delete that file? Thanks in advance...
     
  17. ScootPatoot thread starter macrumors regular

    Joined:
    May 16, 2008
    #17
    SSH into your phone. If you don't know how do a search on this site for SSH and you will get tons of tutorials and walk thru's on how to get into the file system of your phone. Once you learn how to do that, follow my above post. It should work for you.
     

Share This Page