Non-JB IPhone 4 error 1004

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Polar2k1, Sep 24, 2011.

  1. Polar2k1 macrumors newbie

    Joined:
    Sep 24, 2011
    #1
    I have a non jailbroken iPhone 4. Today I updated to firmware 4.3.5 (8L1) after trying to download an app. The app just said waiting and never downloaded after 12 hours and restarting. I updated to iTunes 10.4 today then updated firmware on my iPhone 4. When I tried to update my apps I receive the message "Error 1004 please try again later."

    I have read on here how to fix the jailbroken iPhones with error code 1004. I have not tried restoring it because I have read that some phones are stuck in recover mode.

    Has anyone else had this issue or know how to fix the non-jailbroken iPhone issue of this.

    Thank you in advance.
     
  2. derekcl macrumors newbie

    Joined:
    Sep 24, 2011
    #2
    Iphone 4 error 1004

    I also upgraded to 4.3.5 and have the same problem. Then I noticed the same error with my iPad.

    I found a post on the Apple forums with a fix that didn't seem like it would work but I gave it a shot and it worked only on the ipad. Go in to the preferences under the general tab and change the clock from 12 hr to 24 hr then turn the iPad off then on again and it cleared the problem.

    I guess in order to get my iPhone fixed I'll have to check and see if the genius at the Apple store has a fix for it yet.
     
  3. HeatherLynn macrumors newbie

    Joined:
    Sep 25, 2011
    #3
    I also have a non jailbroken Iphone 4 and I have been upable to update my apps all day. It keeps telling me Err 1004 please try again later. I have tried about 5 times this morning and keep getting the same error. Please let me know if there are any solutions!!
     
  4. JunkyDog macrumors 6502

    Joined:
    Sep 17, 2011
    #4
    Error 1004 and 1013: These errors may be the result of the connection to gs.apple.com being redirected or blocked. Follow these steps to resolve these errors:

    1. Check security software. Ensure that communication to gs.apple.com is allowed. Follow this article for assistance with security software. iTunes for Windows: Troubleshooting security software issues.

    2. Check the hosts file. The restore will fail if there is an active entry to redirect gs.apple.com. Follow iTunes: Advanced iTunes Store troubleshooting to edit the hosts file or revert to default on Windows. See section "Blocked by configuration: (Mac OS X/Windows) > Rebuild network information".

    3. Try to restore from another known-good computer and network.

    4. If the errors persist on another computer, the device may need service.
     
  5. foxyshadis macrumors newbie

    Joined:
    Sep 27, 2011
    #5
    I had the same problem at the office and at home, on the iphone and my laptop; not much chance of it being a hosts problem. The only thing in common: Both locations use OpenDNS. Since gs.apple.com is an Akami alias, this problem will only be noticed by people using the same OpenDNS server as us (since it will resolve to the same Akami server), in my case it points to 17.151.36.30.

    I switched DNS back to the ISP DNS on my laptop and had no problem, but I'm not willing to hassle with setting up a static IP on the iphone to test. Maybe I'll just use Starbucks on the way into work tomorrow. I guess one of the Akami servers is down right now and it just happens to be the one OpenDNS points to.
     

Share This Page