"Non system disk, press any key to reboot"

Discussion in 'Windows, Linux & Others on the Mac' started by shahvrob, Jan 3, 2015.

  1. shahvrob macrumors newbie

    Joined:
    Jan 3, 2015
    #1
    Hallo everybody. Need help installing Windows on a Macbook Pro.

    This is what i have:
    - I have a Macbook Pro 15" late 2008
    - it's running Yosemite 10.10.1
    - my CD-Drive died couple a years ago, so I have replaced it with a SSD: this is my primary drive now; the old HDD is connected internally, too (use it for pictures or music storage).
    - as I bought the SSD, I've installed Windows 7 32 bit using Bootcamp 3 years ago, and it was working perfectly (using it mainly for games).
    - since a lot of games support nowadays 64 bit, I've decided to install it.
    - I have an .iso of 64 bit Windows 7 (according to Apple late 2008 MB Pro supports 64 bit Windows 7)
    - my Bootcamp is 5.1.2
    - using 8Gb USB-Stick (which I've used 3 years ago for installing Windows)

    This is what I have tried:
    - initially, running Bootcamp, it removed my old Windows Partition, so I don't have Windows anymore. Then, it wanted to install Windows, but required a CD (which I am missing).
    - after some days googling I've found a way to change the Info.plist (adding my Model and Boot-Rom Version and removing the word Pre in <key>PreUSBBootSupportedModels</key> in Bootcamp Package, so Bootcamp has now the option to create a USB from .iso
    - so, I've created a USB-Stick with Bootcamp, downloaded all support data and started the process: the problem comes after restart: there is a permanent Apple Logo. After waiting even for the whole night, which did not help, I turn off the Macbook and turn on again: in that case the black screen comes up and it says: "Non system disk, press any key to reboot". Nothing happens till power off. The message comes every time, until I press alt/option during the start and choose Macintosh Drive from the list (which shows me only Macintosh and Recovery: no USB).
    - since nothing worked, I've decided to disconnect my old HDD from the laptop and only the USB with Windows is inserted in the USB-Port: nothing changed, it even got worse: after the reboot from Bootcamp the gray screen stays for like 10 minutes and then the frozen apple logo appears. Restarting the Laptop changes nothing.

    So, does anyone have any idea, what I should try? I've tried 2 different Windows 7 64 bits. Should I borrow an external CD-Drive, burn Windows on DVD and try that? Or is there a problem with 64 bit? Or something else?

    Really appreciate the effort.
     
  2. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #2
    things to try


    make sure the usb key is formatted with disk utility as "master boot record" and maybe even "fat" or "fat23"before writing the usb key with the iso file. , if the usb key is using GUID then erase it

    hold down either the C key during boot or hold down option key during boot and select the usb key

    a sd card class 10 may install windows faster then a generic usb key

    try writing the usb key with someones windows computer instead. with programs like "Rufus" https://rufus.akeo.ie or microsoft usb key maker http://wudt.codeplex.com

    writing the usb key using a windows computer i think requires you to make a separate driver installer disk with the mac

    do you have any other macs with optical drives?? you can use target disk mode to install windows
    -- on the mac with a working CD drive you press and hold the T key during boot
    -- on the mac you want to install windows on, you press and hold the C key
    -- you use either a firewire or thunderbolt cable connected between both macs
     
  3. shahvrob thread starter macrumors newbie

    Joined:
    Jan 3, 2015
    #3
    Thanks

    Thanks for the quick reply.

    - the USB Stick was formatted with disk utility as fat32. However, Bootcamp reformatts it anyway, when it creates the Windows Stick,
    - holding down option key shows Macintosh and Recovery Pertition only - no USB
    - no other macs with Cd Drive are available.
    Maybe it's Bootcamp Problem.

     
  4. shahvrob thread starter macrumors newbie

    Joined:
    Jan 3, 2015
    #4
    External CD-Drive

    So I just borrowed an external CD-Drive from a friend and used it, which worked. Don't know, how to fix it though for using USB-Stick. Until next time.......
     
  5. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #5
    yeah i am seeing this on mac rumors a lot, where bootcamp makes the usb key but the usb key won't boot.

    haven't seen a definite fix yet
     
  6. Maubaraf, Jan 4, 2015
    Last edited: Jan 4, 2015

    Maubaraf macrumors newbie

    Joined:
    Dec 7, 2014
    #6
    Hi you all,

    I am also experiencing this issue, I have a 15' MacBook Pro late 2008 with Yosemite in which I am trying to install a Windows 7 Prof SP1 through bootcamp. My MacBook Pro has an internal optical drive but is not working propperly, it won't recognize the dvd. I know that the dvd is not the issue because it works on my partners Macbook Pro.

    However, I managed to create a iso on my partner's computer, sent it to my computer through Airdrop and then create a bootable USB with bootcamp, bootcamp seems to do everything right but when it reboot my comp this message of Non system disk, press any key to reboot and then I need to force reboot with the power button. If I hold the option key now I get hd and recovery 10.10.1 but no USB option. The startup disk utility doesn't seem to recognize the USB as a bootable device either.

    At this stage I'm stuck, anytime I restart the computer for whatever reason I need to hold option to get to the boot menu to start Os X otherwise I get to a black screen with the message "No bootable device found, insert one and press any key"

    At this point I'd like some helpt please, I am a profane when it comes to computers but I've been reading every single post and I have some ideas, I'd appreciate if you think they are related to the problem or not:

    1.-In order to create the bootable USB on a computer with an optical drive I had to hack the bootcamp changing the info.plst file on the contents, I follow the instructions given on https://discussions.apple.com/thread/5479879?start=105&tstart=0 but on this post there are 2 different ways of changing the info.plst the one I did and the other one in which they do the same thing but they also take the Pre from the line <key>PreUEFIModels</key> and include their MacBook Model indentifier underneath the line. I DIDN'T modify this part of the info.plst and although I am not sure what EFI exactly is I know that is related with being able to boot from USB or not for what I read, do you think that I'd achieve something modifying the info.plst again and then creating the bootable USB again?

    2.- Another possible issue related with my problem that I read is whether if the USB are 2.0 or 3.0, I'm sorry but I don't know how to check that and it definetely doesn't appear in the get info option when you do right click, can somebody tell me how can I find out?

    3.- Also I read that Macs with build-in optical drive won't boot from USB despite of the optical drive not working, however it must be a way to tell the bios to boot from there, also why is startup disk not recognizing a bootable disk that was created by bootcamp?, It doesn't make sense, can somebody please give me some ideas? I'd really appreciate them, thanks.
     
  7. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #7
    I have only seen this issue when booting from USB. If your Mac allows you to make a Windows installer USB in the Boot Camp Assistant, it is capable of booting from a USB installer. I believe this is due to a bug in how the Boot Camp Assistant makes the drives. The workaround is to use a different tool to make a bootable USB drive or install using an optical disk.
     

Share This Page