None of my iPhone apps working...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hellomoto4, Sep 5, 2008.

  1. hellomoto4 macrumors 6502a

    hellomoto4

    Joined:
    Jul 11, 2008
    Location:
    Australia
    #1
    Okay, so heres the deal.

    The other week, I was downloading some apps, like normal.
    When they were finished I went to open the app store, but it froze, so I rebooted my iPhone.

    When it turned back on, I went to try an app, and it crashed and closed. So I tried another. Crashed and closed. Another. Crashed and closed.

    Now none of my apps are working at all - all just crash and take me to the home screen.

    I haven't been able to find a fix for this as yet and its starting to become very frustrating. All the normal apps work (calendar, maps, stocks etc) but not 3rd party ones.

    I don't particually want to delete all of them either as I have 116 apps and it would take forever.

    Help me, please!
     
  2. plasmo macrumors member

    Joined:
    Jul 17, 2007
    #2
    This is a major bug that Apple needs to fix!!!
    Mine is doing the same thing... All my apps close back to the home screen - even if I reset the iphone.
    This has happened to me before, and the only way I was able to fix it was to
    Sync it with my computer and "add another (free) App" from the iTunes store (using your computer)....after it sync and transfers the App to the iPhone, all your Apps should start to work again.

    MY BiG prob is that I am currently on a Road Trip and NOT near my computer to SYNC!!!!! So I won't be able to fix this until I get home from my trip which blows.

    If anyone else has a FIX - please share!
    Thanks
     
  3. AgentXXL macrumors newbie

    Joined:
    Sep 7, 2008
    #3
    I encountered the same 'bug' late yesterday evening. After trying the 'add another app' fix and a few other options, I still was unable to open anything on my iPhone. Worse than that, all my music, playlists and videos were also 'lost' in that the iPod section of the iPhone reported no content.

    Something went seriously awry and my only solution was to do a factory restore, setup as a new phone, and then re-sync all of my info, apps and media to the phone. This took over 2 hours, 3+ if you include the time it took me to re-setup all the apps with their logins, etc.

    I did lose a few minor things like some game scores and progress, and also a few photos I had on the iPhone that were not backed up to my computer. Nothing too serious thankfully. Regardless, I am quite concerned that this could happen again.

    I have serious reservations that the upcoming 2.1 update will rectify this or similar issues. It's my thought/gut feeling after reading posts on various forums about the problems. Hopefully I'm wrong....
     
  4. plasmo macrumors member

    Joined:
    Jul 17, 2007
    #4

    This is EXACTLY what happened to me yesterday!!!
    I got home, and despite syncing to my computer, and resyncing some Apps,
    still NONE of the Apps worked and kicked me back to Home screen.
    In addition, ALL my data (music/vids) in the iPod section were 'erased' or not available, just as you described above!!!
    It took me 3.5 hrs to restore and reconfigure, which is a TOTAL waste of time. Things are back to "normal" for now, but if this happens again, or if many others experience this, Apple needs to get a fix out asap!!!
     
  5. khackney macrumors newbie

    Joined:
    Feb 23, 2003
    Location:
    Texas
    #5
    Something Went Seriously Wrong In Last 2 Days

    My wife and I both bought 3G iPhones on day 1. Over the last 36 hours there have been long periods when the "iTunes Store is Not Available" was all you got when trying the App Store.
    Suddenly yesterday morning all her data was gone and "new" apps on my wife's phone crashed and would not open. She tried restoring from backup which took up hours...then the phone itself died...hours of black screen with white apple then blank screen despite being plugged in for charging.
    My phone is working but all my database apps crashed and won't run. DVDDashboard, StuffRadar, and PocketPedia all fail to run. The most irritating is PocketPedia which had just finished downloading a 1922 item DVD database when the App store announced an update for PocketPedia. The update took at least 15 minutes to load and promptly crashed when started.
    19 of my apps, even free ones, will not reload from backup on my laptop because "this computer is not authorized for this program".
    When I try to download replacements for free they fail to run. My Triple Play Solitare game went down that way.
    It's bad enough that I never really knew what a dropped call was until I left Sprint for the iPhone and have no usable 3G in a zone that should be strong. Now the iPod part has gone bad!

    My first Apple product was an Apple IIe and we got the MacPlus in 1985. We've been MacLoyal over 20 years but I'm beginning to regret this iPhone.
    :mad:
    HELP!
     
  6. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
  7. AgentXXL macrumors newbie

    Joined:
    Sep 7, 2008
    #7
    Sigh, bad news to report. Less than half a day goes by and now my iPhone is again FUBAR! Same exact symptoms. All the built-in iPhone apps do work though, but launch slowly. None of the 3rd party apps work, and again, all my media is missing from the iPod section.

    It is my suspicion that I (we) may have a defective iPhone, specifically the user memory area. Once it fills to a certain level it hits a bad section of the flash ram and that causes corruption of the user memory area, hence affecting the 3rd party apps and all media for the iPod section.

    I read somewhere that there is a method to enter diagnostic mode on the iPhone so you can do a memory check. Time to do some research and see if my suspicions are correct. BTW - in my case it wasn't the addition of a new app that initiated the failure, but instead the addition of new media for the iPod section that probably pushed it 'over the edge'. I still have 3.1GB free space showing according to iTunes, even after the fresh rebuild.

    I'll report back later with my findings...
     
  8. oneals2focus macrumors regular

    oneals2focus

    Joined:
    Aug 21, 2008
    Location:
    Indianapolis
    #8
    Luck?

    I don't know if I got lucky but my apps started working today after not working for about 24 hours. I kept syncing my phone hoping my apps would work and this morning I hooked my iPhone up to my PC. Then I just thought I would run a "Run Diagnostics" on iTunes with my iPhone hooked up. Did that and synced my phone when it was done my apps started working again. :D Now my apps had been working fine then yesterday out of nowhere my apps stopped working. I reset my phone and synced it over and over. Then this morning I did the "Run Diagnostics" thing and my apps work now. So I don't know if I got lucky or not, I probably got lucky. lol But I guess it's worth a try until the 2.1 update comes out. ;)


    Update: My apps were working fine then I had rebooted my phone because the iPod was skipping and now my apps don't work anymore and nothing shows up on my iPod. And the the "Run Diagnostics" thing dosen't work. :( I guess I did get lucky. Man this sucks.
     
  9. mfsot macrumors newbie

    Joined:
    Sep 7, 2008
    #9
    I just bought mine yesterday and am very impressed with the common sense of the way the phone works... that being said I'm having this same problem, I downloaded some free apps, all they do is open, then close and I'm back to the home screen. Day 1 and this is happening is disheartening... now I'm hooked on the run environment...grrrr. waiting for a solution, I will try the above link, please post findings
     
  10. mfsot macrumors newbie

    Joined:
    Sep 7, 2008
    #10
    This post helped me the most from another thread... basically what I did was uninstall itunes and install the 7.0 version, which didn't change much... what I believe fixed my problem was uninstalling them from my iphone then deleting them out of itunes, and going into the itunes store on my laptop NOT MY PHONE and installing them from there, all apps i have installed this way are working.. hope this helps you all


     
  11. AgentXXL macrumors newbie

    Joined:
    Sep 7, 2008
    #11
    Well, after my 2nd failure with the same problem I did a lot of investigation into solutions. I read posts from various forums and eventually used the 'downgrade to iTunes 7.7.0' method. So far so good, although I have had one sync failure while reloading apps to my phone from iTunes on my MBP. The iPhone is currently 'stuck' attempting a sync but I'll let it try for a while longer before I cancel the sync and attempt to restart.

    Dang it, my phone has amazed me with but a few flaws since July 16th. I hope I can regain that sense of enjoyment again soon... :(
     
  12. AgentXXL macrumors newbie

    Joined:
    Sep 7, 2008
    #12
    ARRGGGHHH!! After 3 failures as mentioned above (3rd party apps not working and media 'lost'), I made an even stupider mistake. The downgrade to iTunes 7.7.0 seemed to be working but I was still having some app update issues with both iTunes and the on-phone App Store. Being the adventurous type doesn't always pay off in a good way. I decided to install iTunes 8.0 and guess what? BLAMMO! Same symptoms as iTunes 7.7.1. Sigh...

    Tried deleting apps directly on the iPhone but after a restart they all came back... twice! So I gave up and erased all content again, setup as new iPhone under iTunes 8. Backed up apps to a temporary backup folder and then deleted ALL apps from the iTunes library. I'm now in the process of slowly 're-buying' all my apps from the iTunes app stores. Some I can't get anymore (i.e. PhoneSaber) so I'll have to take a chance that the copies I have in my temp backup folder are not corrupt.

    What a mess... and with my luck it'll all mess up again before I can upgrade to the iPhone 2.1 firmware on Friday. Come to think of it, I'm going to hold off on any app installs until AFTER I get 2.1 working. Sigh... :(
     
  13. hellomoto4 thread starter macrumors 6502a

    hellomoto4

    Joined:
    Jul 11, 2008
    Location:
    Australia
    #13
    I still am yet to find a perfect fix, so I guess the best bet is to do a full restore and upgrade to 2.1 software...

    We'll have to wait and see.
     
  14. GimmeMMS macrumors newbie

    Joined:
    Oct 20, 2008
    #14
    embarrassed

    Oh woe is me, I can't believe I am so mortified I was showing everyone my new iphone in the pub and not a single application would load. Thanks google for indexing this thread at least I got it working again although all my friends think iphone is a joke as nothing works.

    It's so especially embarassing as I had already pointed out that MMS didn't work, the camera is poor and you can't record videos but I said everything else was great, then I got "visual voicemail cannot connect to server", my apps didn't work and rebooting took soooooo long yet did nothing to help.
    :mad:
    I had to end the conversation by saying "but I've been waiting for the Blackberry Storm" so that at least I had some credibility...

    Apple, what should be your shame reflects on me badly. I didn't pretend to anyone my iphone was cool, my friends just saw it and thought it must be great. As I hadn't jailbroken i expected everything to "just work" (yeah right). But thanks macrumors, the answer for me was just to download ANY new app (was already running the latest FW2.1 and Itunes 8.0.1)- apologies I can't find the original post to thank!

    Edit: thanks apple support, obviously NOTHING could be wrong with the software, it must be a hardware issue, right?
     

    Attached Files:

  15. Davidwesty macrumors newbie

    Joined:
    Oct 7, 2009
    #15
    Apps not working Iphone

    Here is what fixed my problem with my third party apps not working just like others have posted here...open the immediately close. I went to the app store and chose a free app to download. When the dowloading started on the app icon(when you can see the download progression bar) press the icon to pause the download. Make sure you are plugged into your computer via usb and power your iphone off then turn the phone back on again. After it completes the sych then go ahead and press the icon on the app you were downloading and let it finish downloading. Now try to open one of the apps that did not work before and it should work.

    This worked for me another time when I had problems with my app icons gettig mixed up...ie holy bible icon would be on wild west pinball.

    Reply back and let me know if this works for you.:apple:
     
  16. MasterDev macrumors 65816

    Joined:
    Sep 14, 2009
    #16
    Or you could just simply install the new free app, and then delete it right after you install it. No restart required and it should fix it. Did that for my friend last night.
     
  17. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #17
    Wow, way to resurrect and old thread. I had this problem way back then but haven't had an issue since with newer firmware/iTunes.
     
  18. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #18
    This same issue is what I am having with my iPhone!
     
  19. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #19
    So, have you tried the fixes suggested? One other way that sometimes fixes this is to deauthorize your computer in iTunes then reauthorize it and resync.
     
  20. scsmith macrumors newbie

    Joined:
    Jan 17, 2010
    #20
    This happened to me this morning with my new 3GS. I thought my children had done something to it, but then had a thought. My work laptop had previously said it couldn't sync my downloaded apps as it wasn't 'authorised', so I authorised it, re-synced the iPhone, and voila! All the apps now work again.

    What is really bad is that the apps just exited without any sort of message that would tell you what was wrong and how to fix it, which when you consider the whole rationale of the iPhone seems to be about User Experience, this is a gapingly huge hole!!

    The other appallingly bad thing is that even if the PC isn't authorised, that's no reason to disable the apps that I have paid money for. What happens if I use another PC to charge the iPhone??

    One little message (and less paranoia and protection) would save so many people so much hassle and prevent Apple's reputation being tarnished - so come on Apple, provide useful messages and behave sensibly.
     
  21. benwmsonline Guest

    Joined:
    Jan 1, 2010
    #21
    I've had this with my iPhone a few times; from what I've learned- resyncing it on a machine that is definitely authorised seems to fix the problem.
     
  22. Fatsayjack macrumors newbie

    Joined:
    Feb 24, 2010
    #22
    Fix!!

    I had this same prob was about to cry .. Then i thought let's try downloading another app and trying it. Right after app was done downloading my apps were all fine
     
  23. Fatsayjack macrumors newbie

    Joined:
    Feb 24, 2010
    #23
    I think it's because when u download new iTunes u need to re enter ur login info.. And it makes u do this when downloading an app
     

Share This Page