nonresponsive screen, restart not working either.. NEED HELP!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SignMyiPhone, Aug 25, 2008.

  1. SignMyiPhone macrumors newbie

    Joined:
    Jul 10, 2008
    #1
    so when i try and open my phone, it just says slide to unlock right? so when i slide to unlock and type my passcode in nothing happens, not only does nothing happen but the little dots that fill in the squares dont even show up.. the sounds are there but nothing happens.. if i try to restart my phone it doesnt work.. however if im at my slide to unlock screen and i double tap home then the ipod still works? and i can receive calls i just cant get into the phone, ive tried opening my contacts book during a call and that wont work either! what do i do?!
     
  2. StoneColdSober macrumors 6502

    Joined:
    Jul 19, 2008
    #2
    I had this happen to one of the iPhones on my account. Took it back to apple and they replaced it on the spot. This was aflfter I did a hard reset, a restore and upgrading to the latest firmware. If you have tried all of those and still no go, setup an appointment with a genius.
     
  3. iJimmy macrumors regular

    iJimmy

    Joined:
    Feb 4, 2008
    #3
    i am having the same problem. i have a 8gb original iphone that i have been using with tmobile usa. its been working perfectly fine until this morning. the touch screen is not functionable anymore.

    this might be a silly question but... i was wondering if i could somehow get a replacement from apple even though i'm not with at&t? does the apple store check if you have a contract with at&t?
     
  4. notwist macrumors regular

    Joined:
    Dec 29, 2006
    Location:
    New Brunswick, NJ
    #4
    Can I just take it to an Apple store even if I ordered the phone through ATT? Will they just exchange it?
     

Share This Page