Normally working bootcamp partition won't load... help!

Discussion in 'Windows, Linux & Others on the Mac' started by white-tt, Jun 4, 2011.

  1. white-tt macrumors newbie

    Joined:
    Jun 4, 2011
    #1
    I've been browsing these forums for a few years now, and have always found the answers I was looking for. So on that note, thanks to everyone! These boards have been awesome. I've been working on this problem for a couple hours now, but can't for the life of me get it solved, so I decided to pop my macrumors cherry, and post up! On to the issue...

    I have a bootcamp partition with windows 7 x64 installed that has worked fine for a few weeks now. I shut it down today, and when I tried to reboot into windows a few hours later it loads the disk, and I get the flashing underscore for about 1-2 seconds. The screen then flashes and restarts (I hear the chime), and defaults to the mac partition. It's as if the windows partition is trying to restart, but since the default target disk is the mac partition, it won't boot. I've tried hitting the option key and booting from the windows partition a second time when it tries to 'restart', but to no avail. It would happily cycle all day restarting until I let it boot in OSX. I noticed windows updater had downloaded updates, and was asking to restart, but I postponed it. I can't remember if I ended up shutting the computer down or restarting, or restarting via windows updater. I'm not sure how relevant that is, but I feel it certainly could be.

    I've tried to reset the PRAM, and SDM with no luck. I wanted to point to a default startup disk in the settings on the mac side of things, but it won't recognize the bootcamp partition as a startup disk since it is formatted as NTFS to support W7x64. What can I do now?! I need to get into the windows partition since I have some files I've just created that haven't had a chance to be backed up, so I don't want to reinstall or reformat if at all possible. Thanks in advance for your help everyone!

    specs:
    MBP 15" with...
    2.2Ghz i7 processor
    8GB (2x4) 1333 DDR3 RAM
    AMD Radeon HD 6750M graphics
    Apple SSD (TS512C) 500GB
    bootcamp is in NTFS format (listed as NTFS-3G in mac system profiler), 100gb, running windows 7 (64 bit)
     
  2. white-tt thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #2
    bump.

    anybody? I still can't get it to boot into windows!! :confused:
     
  3. drjasonharrison macrumors newbie

    Joined:
    Jun 6, 2011
    #3
    Can disk utility from the Mac OS X side fix it? I seem to remember fixing a problem like this using it. Parallels had messed up my bootcamp partition and I couldn't boot either the Parallels VM or the computer from the windows partition.
     
  4. white-tt thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #4
    I can erase/re-format the partition using disk utility, but I would like to avoid that at all costs. That would mean starting from scratch since I don't have that partition backed up yet. :(

    How else could disk utility 'fix' it? Am I missing a feature of disk utility? (Verify and repair don't work since the partition is NTFS)
     
  5. drjasonharrison macrumors newbie

    Joined:
    Jun 6, 2011
    #5
    Sorry, I must be misremembering. If you have a windows install cd you can boot from that and run chkdsk.

    But checking my disk utility, it can verify and repair my bootcamp NTFS disk.
     
  6. white-tt thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #6
    First, thank you for your replies/help. They are much appreciated.

    I will try the windows disk when I get home to see if that has any luck.

    My disk utility says it can verify and repair (they're not greyed out), but when I actually try to use them it gives me a message saying NTFS not yet supported, and that it will complete reporting/fixing no errors.
     
  7. white-tt thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #7
    I tried using the windows disk. I threw everything it had to offer at it. I even rolled back before my last updates. No dice. Looks like I'm going to have to wipe the partition, and reinstall windows. I'm sad it comes to that since I'll be losing some decently complex solidworks drawings along with several hours to reinstall all the software.
     

Share This Page