Not able to boot into single user mode (Apple+S)?!@#

Discussion in 'Mac Help/Tips' started by coolbreeze, May 1, 2003.

  1. coolbreeze macrumors 68000


    Jan 20, 2003
    I am trying to run fsck -y in single user mode. That's all fine and everything, but I cannot seem to reboot into the "single user mode" everyone talks about.

    I select "reboot" from the apple, then after I hit "yes," I hold down Apple-S. I get the spinning circle (not beachball), the "gong"...then the grey screen with the apple on it, then another spinning circle, then the graphical login "UNIX dungeon of command line horror."

    All while still holding down the Apple-S buttons.

    What, exactly, am I doing wrong? Should I wait until the gong to depress the buttons? When should I release? Why is the sky blue?

    By the way, I've seen conflicting reports on the fsck it

    1. fsck -y
    2. /sbin/fsck -y

    help please.
  2. RBMaraman macrumors 65816


    Jul 25, 2002
    Prospect, KY
    You just hold down the "S" key, and not "Apple+S".

    Also, the command is fsck -y.
  3. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    you have to hold down apple+s, that's what apple says.
    it's "/sbin/fsck -y"
    hold down the two keys as soon as you see the gray screen and before you see the round indicator thingie below the apple logo.
    when you do fsck and it says that the volume has been modified, do it again, after you're done type in "reboot" to restart the computer.
  4. zimv20 macrumors 601


    Jul 18, 2002
    Re: Not able to boot into single user mode (Apple+S)?!@#

    it's the same thing. there's only one fsck and it's in /sbin

    so unless you changed your root PATH and removed /sbin, it'll find it.

    or if you suspect someone got onto your machine, made a fake fsck and stuck it /usr/local/bin or your home directory, then you should specify the full path to make sure you're getting it from the right place.

    but anyone who can do the above can also mess with /sbin/fsck. oh, security woes.
  5. coolbreeze thread starter macrumors 68000


    Jan 20, 2003
    Thanks for the responses. I figured out my problem...the Apple+S key combo doesn't work with my keyboard.

    About a month ago, I spilled water on my Apple Pro keyboard, and have been using my Microsoft Natural Pro keyboard since. It works great, but I need another Apple to replace this one.

    So I plugged my Apple keyboard in, rebooted, and it worked. The only problem is that several keys don't work (after the spill) so I had to swap the keyboards while at the command prompt. Pain in the ass, but it worked.

    And to think I was about to trash my Apple keyboard (about 7 keys no longer work....)

Share This Page