Not able to install Safari in MAC OS X Lion

Discussion in 'Mac Apps and Mac App Store' started by vlnarasimham, Sep 20, 2011.

  1. vlnarasimham macrumors newbie

    Joined:
    Sep 20, 2011
    #1
    Not sure whether it's a bug in LION, i had LION running on my Mac and i just un installed Safari as i see some browsing issues. When i downloaded Safari 5.1 and tried installing it, i got the error saying i should have MAC OS X 10.6 to install....


    Any help would be greatly appreciated
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Remove the Safari 5.1 receipt bundle and retry.
     
  3. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #3
    Duff-Man says....I think your issue is that the version of Safari that you d/l from Apple is the version for 10.6 SL. Lion ships with Safari 5.1 as part of the OS install so there's no installer for it at Apple as a separate download. You'll likely need to dig into your Lion install package and find the package for Safari in there....you did back up the installer, or have a backup of some sort hopefully? You should be able to use Pacifist to find the installer you need (I don't have it in front of me so can't give you the full path to follow)....oh yeah!
     
  4. vlnarasimham thread starter macrumors newbie

    Joined:
    Sep 20, 2011
    #4
    Well, i restored LION , holding CTRL + R while rebooting and choosing restore MAC OS option and that worked fine. i am now able to use Safari. Thanks for all your suggestions
     

Share This Page