Not able to mount an external drive

Discussion in 'macOS' started by marklight, Jan 3, 2009.

  1. marklight macrumors 6502

    Joined:
    Apr 6, 2006
    #1
    So I have this sans digital USB towerraid enclosure, with one, 1TB drive in it. It's formated as NTFS. It was working just fine, but for some reason, I went to connect it to a windows machine today and it basically froze up the computer. so i tried a few things, and it was still freezing the computer.

    So i connect it to my macbook pro where it normally is, and when it tries to mount the device i get an error from NTFS-3G. I added an attachment of the error it gives. I tried inserting the command line it suggests in terminal , but it didn't really do anything. I'm not really familiar with terminal or how to use it fully.

    I was thinking maybe it had something to do with the towerraid system. So i took the drive out of the raid system, and plugged into my windows desktop via sata. once again, it locks up my computer. I'm not sure what to do.

    Any suggestions?
     

    Attached Files:

  2. LUNA macrumors newbie

    Joined:
    Jan 3, 2007
    #2
    You will get this error when you unplug a USB device from a windows system without using the "remove the device safely" function. If the commend line doesn't work, you can follow the first option, just connect it back to any windows system and then click the icon that looks like a green arrow in the system tray, select "remove it safely" (or simply shut down the computer because sometimes it doesn't allow you to remove it for some reason). Then it should be fine when you reconnect it to your mac.
     
  3. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #3
    Why does OS X care about this? In other words, what would be the potentially negative impact of forcing a mount despite the lock (or 'unclean shutdown')? Isn't mounting NTFS partitions on OS X a read-only affair (by default)?
     
  4. LUNA macrumors newbie

    Joined:
    Jan 3, 2007
    #4
    I think it is actually the NTFS-3G that caused this problem. NTFS-3G enables write to NTFS drives. I have had this problem with NTFS-3g in linux.
     

Share This Page