Not able to remove Windows through bootcamp

nirmal3913

macrumors newbie
Original poster
Jan 14, 2017
4
0
Melbourne - Mumbai
Hey mates,

So I have been trying to remove windows which I had initially installed.

Whenever my iMac restarts by default it opens a black screen "no bootable device insert boot disk and press any key"

Unfortunately, in "boot camp assistant" I cannot see any remove option. (check attached)

Also, disk utility shows there is no more windows partition (check attached)

If I have already removed everything, why does it still show no bootable device insert boot disk and press any key" when I restart my pc?

Any help appreciated.

Regards,
Nirmal
 

Attachments

DeltaMac

macrumors G4
Jul 30, 2003
10,131
2,640
Delaware
Did you use the normal process in the Boot Camp assistant to remove the windows partition properly? Or did you use some other method to remove the windows partition, such as Disk Utility (which can work, but leave you in the state that you have now, or maybe not even bootable, even into macOS) The ONLY method that you should use to remove a Boot Camp partition, is the Boot Camp assistant.

Can you still boot to macOS? If you can, then make sure that your Startup Disk has your macOS drive selected.
That should allow you to boot to macOS without trying to use the EFI partition to boot Windows (which likely still exists)

Also, can you post a screen shot of a terminal window, showing the results running the command
Code:
diskutil list
 

Erdbeertorte

Suspended
May 20, 2015
1,180
500
Hi,

you could try the Paragon Hard Disk Manager (there is a free trial version) to fix BootCamp.

https://www.paragon-software.com/home/hdm-mac/

It worked for me after upgrading to High Sierra and APFS. It should reappear in System Preferences/Startup Disk and also the BootCamp Assistant should recognize it then as removable.

There are two options. I just used both of them, so I don't know which one fixed it. The options show up if you click on the "gear wheel" of the BOOTCAMP NTFS partition.

Screen Shot 2017-08-12 at 4.17.43 AM.png


Screen Shot 2017-08-12 at 4.10.29 AM.png
Screen Shot 2017-08-12 at 4.10.55 AM.png
 

Galanthus

macrumors newbie
Feb 7, 2019
1
0
I'm having a similar problem. I am not a mac user and so my grasp of how this works is quite limited. I tried to install Windows and the process had started but failed to finish. On trying to go through the process again I received the error message, that 'The startup disk cannot be partition or restored to a single partition.

I then used disk utility to try and delete the volume - maybe this is where I went wrong (DeltaMac above advises that you should never do this!).
I now have a 'Container Disk1' partition that I cannot seem to remove or merge back to the Macintosh HDD.

Would anybody kindly advise as to what I should do next?

Cheers

Gareth
Screenshot 2019-02-07 at 18.07.09.png

Screenshot 2019-02-07 at 17.48.24.png
Screenshot 2019-02-07 at 18.05.20.png
Screenshot 2019-02-07 at 18.05.35.png

Screenshot 2019-02-07 at 18.05.49.png
Screenshot 2019-02-07 at 18.06.11.png
 

Similar threads

  • GreggC
0
Replies
0
Views
764
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.