Not connecting to preferred networks automatically

Discussion in 'MacBook Air' started by agentphish, Dec 18, 2011.

  1. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #1
    When waking from sleep, my 2011 air will not auto-join my 5ghz wifi network.

    My network is coming from a 2011 Airport Extreme Dual Band.

    It worked 100% of the time perfectly before I changed to the 2011 AEDB. Previously I had a 2009 version of the same Dual Band router.

    Any ideas? Seems strange to me. It's all apple gear.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Is it at the top of your Preferred Networks list in System Preferences > Network?
     
  3. destroyboredom macrumors 6502

    Joined:
    Dec 16, 2002
    Location:
    Washington, DC.
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I heard there is a bug in 10.7.2 the causes issues with the air and it not auto connecting to wi-fi. Apparently turning off Bluetooth helps.
     
  4. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #4
    yeah I don't use bluetooth. Only network in my preferred networks is my 5ghz.

    I killed the systemconfig file last night and rebooted, today after a day at work, It did connect properly, maybe just a corrupt pref file. I dunno.
     
  5. LordVic macrumors 601

    Joined:
    Sep 7, 2011
    Location:
    Ontario
    #5
    I have 2 Wi-fi access points in my house. one in the basement, one upstairs.

    when i'm downstairs, it auto connects to the 1 bar upstairs signal

    when i'm upstairs it auto connects to the 1 bar downstairs signal.

    never does it seem to be smart enough to connect to the closest highest signal.

    if i'm upstairs and it can't see downstairs, it pops up and asks

    if i'm downstairs and it can't see the upstairs, it pop ups and asks

    I think my wi-fi on the laptop is trolling me
     
  6. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #6
    well both the 2 and 5ghz have full signal everywhere in my house. it's a duplex but is a decent size at 1500 sq. ft. I never had an issue with my previous AEBS.

    This one, though I read the signal and range were supposed to be better on the 2011 model, has proven no better in terms of overall signal strength. Not sure why that is considering it does have extra antennas.
     
  7. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #7
    issue is intermittent at this point. Have been sleeping and waking my MBA at various intervals all day long as I have been home. I'd say about 30% of the time it does not auto-connect to my preferred network and brings up the window asking me what network to connect to when I wake it.

    This is a bummer. It's so strange though because I have to believe that it could be related to my new Airport Extreme because I never had this issue with the old (2009) one.
     
  8. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #8
    It's a known issue with Lion. I've heard reports that this is largely fixed with the 10.7.3 beta.
     
  9. LordVic macrumors 601

    Joined:
    Sep 7, 2011
    Location:
    Ontario
    #9
    how about windows?

    anyone run their Air with win7 and notice if the same issue happens?
     
  10. fluffymuha macrumors newbie

    fluffymuha

    Joined:
    Nov 5, 2011
    #10
    I had the same problem (as many others, i presume) and I took my air into the Apple store and they pretty much deleted the system config file and did a reboot. It now automatically connects to my preferred network every time, without any problems :)
     
  11. LordVic macrumors 601

    Joined:
    Sep 7, 2011
    Location:
    Ontario
    #11
    fixed the issue for the time being by completely wiping all wireless profiles and starting from scratch
     
  12. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #12
    I have the same issue. It's completely intermittent and happens on n and g wifi networks on both channels. I haven't tried lord vic's suggestion yet.
     
  13. AppleTech22 macrumors 6502

    Joined:
    Jul 10, 2010
    Location:
    US
    #13
    I have tried resetting up the whole Wi-Fi and I am still plagued by this problem.


    Also if anyone could point me in the direction for why the internet will be working fine for a while and then just stop. I will then try network diagnostics and it shows the bottom two lights yellow, as shown in the picture. Already tried turning on/off modem, router, and Airport. On the old UFO looking AirPort Extreme in case you're wondering.
     

    Attached Files:

  14. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #14
    my issue is still ongoing. I've tried all sorts of stuff i've found online and suggested to me by my friend who's in the know at an apple service provider.
     
  15. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #15
    whether you use bluetooth or not, if it is on it will make this happen

    make sure it looks like this:

    [​IMG]
     
  16. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #16
    As I stated before on Dec 19, 2011 07:10 PM I do not use bluetooth at all. I know very well how to turn it on and off. I've been a mac user for 10 years at this point...Frankly I hate bluetooth...

    It has been turned off since I got my machine. ;)
     
  17. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #17
    again what is so strange is that I had ZERO issues when I had my 2009 model dual band. Literally the first day I had my 2011 model at the beginning of December I began to have this issue, however I have reproduced it now with other brands of routers.
     
  18. theIlluminati macrumors newbie

    Joined:
    Aug 22, 2011
    #18
    WIFI not found.

    I have been having problems with my 2011 MBA with it not connecting to my airport express. So I have changed the settings to 5ghz wireless N and set the multicast rate to 24mbps and use wide channels. And so far all is good no connection problems from wakeup.
    Hope this helps.
     
  19. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #19
    trying to help, regardless of whether you use bluetooth or not has no bearing on if it is on.
     
  20. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #20
    This is interesting information. I will check it out, test, and let you know what I find with my setup. Thanks!
     
  21. agentphish thread starter macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #21
    So I have slept and woke twice at random intervals since my last post, so far so good.

    In my Airport Extreme I changed from Multicast: Medium to Multicast: High and changed my WPA Group Key Timeout from 1 hour to several days.

    I will continue to post further results.
     
  22. Jbuchan83 macrumors newbie

    Joined:
    Jan 18, 2012
    #22
    I had the same problem and I turned off "ask to join new networks" in network preferences and it fixed the problem.
     
  23. navarretemarce macrumors newbie

    Joined:
    Jan 23, 2012
    Location:
    The end of the world (for real)
    #23
    Exactly the same issue as described by agentphish.

    This fix sound interesting:

    Unfortunately I bought MBA for its portability. I need to connect to a 10 or more different WiFi networks of my customers every day. Would be a real pain to ask them to re-configurate their routers because I own a MBA :confused:.
    I am seriously disappointed and I hope they release a patch soon
     

Share This Page