not having one album in itunes...help?

Discussion in 'Mac Basics and Help' started by gusious, Mar 31, 2008.

  1. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #1
    hi...I am kind of new and i would appreciate your help...

    well,my problem is this:when i import a cd with i tunes or just some songs for my memory stick(for example nirvana),with the cover flow mode,the songs aren't presented in the same album but as if they were different.So i used command+I when i chose them all to put the same artist and album name...But,nothing happend...

    Can you help me??????


    Thanks very much!
     
  2. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #2
    Hi,

    make sure the information in the ID3 field Artist and Album Artist is either the same or the field Album Artist is empty for every track.

    This should do it.
    /Rupert
     
  3. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #3
    thanks for the answer but i tryed both of them but none of them worked...Anyone else any ideas?
     
  4. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #4
    Hi,

    did you also sort by Album by Artist instead of Album only?

    /Rupert
     
  5. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
  6. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #6
    Ok,

    maybe you go over all the information in the ID3 again. Write stuff like Artist and Album into the fields again.
    Also, check the fields that should be empty (so all are changed to empty).

    We're going to tackle this, as sorting IS based on ID3 tags.
    /Rupert
     
  7. j.bond312 macrumors newbie

    Joined:
    Jan 30, 2008
    #7
    Ok just try this, select 'all' of the songs and select 'Get Info' now in this new box, make sure firstly that all of the information is the same, then make sure that all of the tick boxes have been ticked.

    The one i want you to take the most note of is the 'Compilation' box, as i feel that you have a few songs that are set to be part of a compilation whilst the others arent, which makes the multiple covers appear. Either set the compilation to Yes or No and make sure that the tick box next to it is selected, then apply the changes.

    Hope that helps!
     
  8. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #8
    thank you guys for all your help but still....i have the same old problem.....

    Can anyone else help me?
     
  9. LouisBlack macrumors 6502

    Joined:
    Jun 21, 2007
    Location:
    Balham, London
    #9
    Annoying I know, but have you tried stripping off all of the info and re-entering it? Or if worse comes to worst, you could burn the songs to disk and re-rip it.
     
  10. j.bond312 macrumors newbie

    Joined:
    Jan 30, 2008
    #10
    To be honest you must be doing something wrong, if you selected every single song that you have within that album, made sure 'all' the boxes have blue ticks in them, made sure you have selected 'Yes' under the compilation option, then there is absolutely no reason for it not working....

    Heres an example of your problem:

    I have one album, yet it for some reason has been separated into two:

    [​IMG]


    I then select all of the songs that have been separated into two albums and right click and 'Get Info' and tick all of the boxes, also enter the Artist, Album Artist and Album if its not already shown within the 'Get Info' window.

    [​IMG]

    After hitting OK they are now in one album

    [​IMG]
     
  11. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #11
    well i did exactly the same thing you told me but...nothing......Do you think that this problem is because i didn't insert it from a cd but from a usb memory stick????


    ...............
     
  12. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #12
    iTunes does not differ, if you rip the songs from a CD or import them from a memory stick. Only difference is that iTunes takes care of the naming (and putting together the album) when you rip it with iTunes.

    However, I found this article over at Apple.

    Maybe this helps you.
    /Rupert
     
  13. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #13
    i'm kind of dissapointed... i mean i have tryed every single thing you've told me....But still nothing.... i really can't understand where is the problem...:(:(:(

    Is there someone else that has any new ideas?
     
  14. montycat macrumors 6502

    montycat

    Joined:
    Mar 19, 2007
    Location:
    Florida
    #14
    Thanks for the link. I now have my iPod completely organized! I had many split and partial albums. MC
     
  15. rgurgel macrumors newbie

    Joined:
    May 3, 2008
    #15
    Command+I, check "COMPILATION" box and set it to YES

    HEY MAN.

    I Think that you don`t undestanding what our friends.

    Did you try:

    1. Select all that u want to be a one "single compilation";
    2. Press Command+I;
    3. Check "COMPILATION" box;
    4. Set Compilaton as YES;
    5. Click OK.

    It`s solved the same problem for me.
     
  16. Delameko macrumors member

    Joined:
    May 1, 2008
    #16
    I'm wondering...

    Perhaps when you copied them over from your memory stick they became (or were) read-only? And so iTunes can't change them.

    Find the MP3 files in Finder, ctrl/right-click on one of them and make sure you have Read & Write permissions in the Sharing & Permissions box.
     
  17. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #17
    well it has read and write permissions for me.For groups and others it has only read
     
  18. gusious thread starter macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #18
    God, i just found the solution and it was too damn easy....

    I had my song sorted by Name and not by album or artist....

    Finally....!:rolleyes:
     

Share This Page