Not Internet Connection After Resume from Sleep- Every time!

Discussion in 'OS X Yosemite (10.10)' started by iphnhelp, May 15, 2015.

  1. iphnhelp macrumors regular

    Joined:
    Jun 16, 2010
    #1
    Every time I resume from sleep I have no internet connection. Wifi is connected, it looks like it should be working, but no internet. I have to turn Wifi off and then back on. Then it immediately connects. This happens almost every time I resume from wake up. I've tried resetting various things, removing the network and re-adding it. Same behavior. This happens on various Wifi networks in different locations. Anyone experience the same issue or have a fix?
     
  2. Hdub32 macrumors newbie

    Joined:
    Feb 19, 2015
    #2
    I'm having the same issue but have no fix as of yet. I have a feeling my macbook does not like my router.
     
  3. bradl macrumors 68040

    bradl

    Joined:
    Jun 16, 2008
    #3
    Not happening to me on my mid-2011 MBA. So it may help to know which year and model of Mac this is happening on.

    BL.
     
  4. Hdub32 macrumors newbie

    Joined:
    Feb 19, 2015
  5. twintin macrumors 6502

    Joined:
    Aug 10, 2012
    Location:
    Sweden
    #5
    Had something similar like 2 years ago. Had to change channel on my router to make it work again.
     
  6. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #6
    Mine happens when it refused to connect to my router at all... And when it does, it gives a self-assigned IP address. Sometimes it will reconnect itself after a few minutes.

    Happens on both Snow Leopard and Yosemite, so it's either my Mac or my crappy router...
     
  7. thejasonhowell macrumors regular

    thejasonhowell

    Joined:
    Nov 14, 2013
    Location:
    Charleston, Ill
    #7
    Apple "fixed" what worked in prior versions with something that was completely broken.

    But now they're replacing it again.

    http://www.macrumors.com/2015/05/26/apple-discoveryd-replaced-with-mdnsresponder/

    Snow Leopard? Must be something else...
     
  8. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #8
    I too have this issue. I actually came to the OS X forum just to post about it, but then I saw this thread. It's unacceptable. It says it's connected but there's a big exclamation point through it. Calling Apple tomorrow. I'm really effing sick of it. Been waiting for a fix ever since Yosemite came out and nothing. EVERY SINGLE GODDAMN TIME I WAKE IT FROM SLEEP!!!!! I hate it. And if I were a new Mac user, this would be a major turn off. I can't imagine giving this laptop to my mother who would call me to tell me the internet doesn't work every single time she opens her computer.
     
  9. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #9
    Like I said, it's self-assigned IP address... I wonder if this Yosemite bug is big enough to screw up hardware that it now affects older versions of OS X...
     
  10. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #10
    I hope not. But if that's the case then I'm lucky I got AppleCare on this MBA because it's 2 years old already. It's weird, the wifi symbol has an exclamation through it, but if you click on it and open the wifi drop down menu it actually shows that it's connected to my home network. The only solution is turning wifi off and back on. I find myself doing this almost every time I open my laptop and it's to the point of being a major annoyance.
     
  11. sevimli macrumors 6502a

    Joined:
    Jun 26, 2007
    #11


    Mine solution: Apple Airport Extreme or TimeMachine, zero problem.


    Whenever I use a third-party router this problem occurs again. I tried Netgear R7500, Linksys EA9200 etc, all high end routers, got the identical issue on my macbook pro. I have to manually turn-off and turn-on wifi. As soon as I switch back to my airport extreme, all works just fine!

    I get better coverage with these other brands, but having this issue *all* the time. decisions decisions...
     
  12. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #12
    This has been much discussed on this forum.

    There is quite a sizeable minority having this problem, all with different routers and macs with the constant being that we are all running Yosemite. At the moment there is no fix however, apparently the latest version of Yosemite is suppose to fix this (although, it's been in the fix notes for every update since Yosemite has been released so I'm not counting my chickens just yet).

    Keeping my fingers crossed.
     
  13. iphnhelp thread starter macrumors regular

    Joined:
    Jun 16, 2010
  14. TangoCharlie27 macrumors member

    Joined:
    Apr 18, 2015
    #14
    Ive upgraded to El Capitan and so far so good! Speed is superfast and not 'searching for networks'.
     

Share This Page