iPhone Not receiving all iMessages on phone after 8.4 update

Discussion in 'iOS 8' started by jww062, Jul 5, 2015.

  1. jww062 macrumors member

    Joined:
    Dec 1, 2012
    #1
    I updated to iOS 8.4 from 8.3 on Tuesday. My iPhone 5s isn't getting all of my iMessages -- I'm still getting them through Messages on my Macbook Pro.

    I turned off text forwarding to my Macbook to see if that helps (although now I'm worried I might not get some of them at all).

    I tried turning iMessage on and off on the iPhone, I logged out of iMessage and logged back in... no luck. And my phone number is checked as one of the accounts receiving them, and I do get some of them... just not all.

    Any ideas?

    ETA: No issues with regular SMS messages to other non-Apple devices.
     
  2. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #2
    What about removing all entries except your mobile phone number from the send and receive list?
     
  3. jww062 thread starter macrumors member

    Joined:
    Dec 1, 2012
    #3
    It's the only one I have enabled, on the iPhone and in Messages on the Mac (before I shut off the forwarding to it, anyway).
     
  4. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #4
    I don't have a Mac, but I'm wondering if receiving iMessages on the Mac have something to do with your issue.
     
  5. jww062 thread starter macrumors member

    Joined:
    Dec 1, 2012
    #5
    I've had the forwarding setup for several months (since I got this new MacBook in October) without an issue. I updated to 8.4 on Tuesday, and the first occurrence of a missed message on my phone was 8am Wednesday morning. So I think it has to be 8.4 related.

    As I said, it only occurs with iMessages (not regular "green" SMS), but not all iMessages, and not even all iMessages from a person... some go through, some don't.

    I also verified that it has nothing to do with reading the message on the mac before it appears on the iPhone -- some of them have appeared when I turned on my Mac hours after the message was sent and should have appeared on the phone (which was on and receiving other iMessages in the mean time).
     
  6. mkaen macrumors regular

    Joined:
    Jun 7, 2011
    #6
    Did you ever find a solution? Same problem here.
     
  7. jww062 thread starter macrumors member

    Joined:
    Dec 1, 2012
    #7
    I ended up switching to the iOS 9 beta.
     

Share This Page