Not receiving geofence alerts in Find My Friends

Discussion in 'iOS Apps' started by noanker, Sep 30, 2015.

  1. noanker macrumors member

    noanker

    Joined:
    Sep 30, 2015
    #1
    Hello all.

    I've been using Find My Friends for over 2 years now and have rarely ever had issues with it. Since updating to iOS 9, I am no longer receiving geofence alerts from my wife's phone. We're both running iOS 9.0.2, both phones are iPhone 5s. Previously, her alerts have come across without incident.

    My wife receives my geofence alerts but I do not receive hers. Again, all alerts were working great until we upgraded to iOS 9. Following the upgrade, I am no longer receiving her geofence alerts on my iPhone or any of my iDevices.

    Here's the troubleshooting I've done since the issue began:
    • Rebooted both devices
    • Ensured that my phone wasn't muted
    • Ensured Background Refresh is on for both devices and that FMF is open and running in the background
    • Checked that her phone had the correct contact selected to share location with; checked that I had the correct Apple ID running on my FMF
    • Deleted and rebuilt the geofence alerts that she had
    • Tested the feature where my wife's phone could notify mine of its current location which was received successfully
    • Closed and reopened FMF on both devices and rebooted again
    • Ensured "share my location" was on in System Services
    • Ensured Wi-Fi was running on both devices
    • Ensured that Do Not Disturb isn't running.
    I did a search of this forum to check if anyone was experiencing a similar issue and was unable to come up with anything recent, hence my posting this here.

    I am puzzled as to why her alerts are no longer coming through as they used to. Can anyone shed some light on what may be the issue? Have you experienced this previously? What was your solution?

    Thanks!
     
  2. noanker thread starter macrumors member

    noanker

    Joined:
    Sep 30, 2015
    #2
    Well, I'm answering my own post here. I have found the solution to the problem and hope that it will yield a resolution for someone else in the future, should they encounter this issue.

    Solution: Settings > General > Reset > Reset Location & Privacy **

    **
    Be certain you only reset location & privacy ONLY!

    Following this action, I am receiving all geofence alerts. Not sure what caused this issue, although logic would indicate the iOS 9 upgrade may have triggered it, but the lack of online complaints of this type would suggest it's not widespread. Or it may be a total fluke.
     
  3. noanker thread starter macrumors member

    noanker

    Joined:
    Sep 30, 2015
    #3
    OK, well, that was a short-lived fix. Back to not receiving any FMF alerts.

    Anyone else having similar issues? Any ideas? Before posting a suggestion, please read my original post and the steps I've already taken.

    Thanks ;-)
     
  4. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #4
    My FMF has been also acting funny and I am currently on the 9.1 beta. It will not send alerts sometimes and others they come through at random times.
    Plus it doesn't seem like there is a way to turn off the geofence for a particular person so I don't know how this 'setting' could be being what is triggered.
    In all I hope this is just meaning that a larger update to FMF is coming to make it a little more user friendly and powerful.
     
  5. noanker thread starter macrumors member

    noanker

    Joined:
    Sep 30, 2015
    #5
    I would think if you want to no longer receive a geofence alert from a particular person, you'd have to have them access their FMF and then under "Me" -->"Notify Friends" delete the particular alert(s) you no longer wish to receive.

    But I think there should be a mute option so a user can just swipe left and select "mute."
     

Share This Page