Not recognizing external USB hard drive

Discussion in 'PowerPC Macs' started by cook.675, Oct 17, 2011.

  1. cook.675 macrumors member

    Joined:
    Sep 24, 2011
    #1
    Powermac G5 dual 2.0 GHZ, Leopard 10.5.8

    I have an external 500 GB that up until yesterday worked fine. Everytime I plugged it in, there it would be.

    Now finder doesn't recognize the drive, and plugging it in/unplugging it doesn't do anything. I can open up disk utility and the drive shows up there, howevere I can't do anything with it here. I've tried to hit 'eject' from disk utility and it says 'volume can not be ejected, try closing applications blah blah blah' even though there are no applications open.

    Any ideas how to make this work again?

    PS I MAY have unplugged it without 'ejecting' it. Im not sure if this is the issue or how significant this is.

    Please help!

    Thanks
     
  2. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #2
    Open the Console program in the Utilities folder and see if you're getting any messages about it. If you are, post them here.
     

Share This Page