Not recognizing first keystroke after being idle

Discussion in 'MacBook Pro' started by afultz075, Aug 5, 2007.

  1. afultz075 macrumors member

    Joined:
    Jun 23, 2007
    #1
    I notice sometimes that if I don't type anything with the keyboard for a few minutes, that when I resume typing the computer does not input the first keystroke. Does anyone else have this issue? IIRC, the SR MBP I had before this that I got replaced did this as well.
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    Yes, my PowerBook has had this issue for well over a year. It was introduced in one of the Tiger point releases and never fixed. It gets mentioned here every once in a while by someone, and lots of people pipe up to say they have the issue. But no resolution that I know of.
     
  3. Kaptajn Haddock macrumors regular

    Kaptajn Haddock

    Joined:
    May 10, 2007
    Location:
    Denmark
  4. azhelkov macrumors member

    Joined:
    May 31, 2005
    #4
    Try to disconnect mouse and see what happen. There is something about energy saving and bad implementation of USB1.1 in USB2 controller in MBP. In my case, however, both USB and wireless mice cause a problem. Or Bluetooth mouse still USB device? May somebody clear it up?
     
  5. theheyes macrumors regular

    Joined:
    Mar 8, 2006
    Location:
    Manchester
    #5
    Ive had my MacBook well over a year and this has only started to happen since I installed Leopard.
     
  6. azhelkov macrumors member

    Joined:
    May 31, 2005
    #6
    Unfortunately this issue was known long before Leopard. I found on Apple mailing list topic "MacBook Keyboards & USB ports (was Write takes too long to return)" back in March 2007.
    Q. "... Also, why the suspend in periods of inactivity? I've found that I have to "wake" the keyboard or trackpad (at times, initial touch isn't registered, even when there are no external devices enumerated.) Are the power savings that significant? - I recognize the spec states that devices on the bus should tolerate this, but it seems to affect the normal use of the laptop."
    A. "The power savings is significant. It took a great deal of work, and is one of the reasons for superior battery life on MacBook systems vs the same chipsets in systems that ship with Windows.
    We're aware of the underlying suspend/resume issue and will try to develop workarounds that don't impact other devices.

    David Ferguson
    USB Software Team
    Apple"

    I have a bad feeling that this bug is something fundamental and would NEVER be fixed. Prove me wrong, Apple.
     
  7. HALTAH macrumors newbie

    Joined:
    Dec 29, 2007
    Location:
    South Jersey Shore
    #7
    This happens to me quite frequently. My software is completely up to date and it's a brand new MBP (only 3 week old). Strange how its only the first keystroke that misses. Really my only complaint about this lovely computer.
     
  8. bonecandy macrumors member

    Joined:
    Oct 3, 2006
    #8
    Well, after reading azhelkov's post, it actually makes me feel a little better. It's intentional. It's not really a bug per se, but a consequence of the keyboard being put to sleep which apparently saves a lot of power. The reason only the first keystroke is missed is because the first keystroke wakes up the keyboard, I'm assuming.
    The bug part, in my opinion, is that this shouldn't be happening if the power adaptor is plugged in. I could accept this if it only happened running on battery, however.
     
  9. azhelkov macrumors member

    Joined:
    May 31, 2005
    #9
    I would call it paranoid. Anyway, battery life aside, there is still a conflict somewhere. I am wondering if somebody can get rid of this annoyance by simply disconnect USB peripherals. It seems better in my case, but it's so not reproducible, hard to say for sure. Another suggestion is to switch USB ports. They are not equal. When mouse is connected to right port, it is sharing bus with keyboard/trackpad. If to the left, then it is on the bus with Bluetooth. It feels a bit different but does not eliminate problem in my case. Would be nice to have some statistics to present a case to Genius.
     
  10. z2000000 macrumors newbie

    Joined:
    Feb 12, 2008
    #10
    missing first keystroke

    I have the same problem as the original poster. I have contacted apple care, gone to the apple store and gave my machine to a mac genius who wanted to send it to apple for god knows how long to "possibly find a problem." Pass. I need my machine every day, not four weeks from now when apple decides to send it back to me. I've had the keyboard replaced and used an external. There is no difference, the problem persists. It is not a hardware issue, it is a software issue. Apparently this has been going on since early tiger. There are numerous threads:

    http://discussions.apple.com/thread.jspa?messageID=6578448#6578448

    http://forums.appleinsider.com/showthread.php?t=81413

    http://discussions.apple.com/thread.jspa?messageID=6522928

    Many others.

    Solutions? what solutions?
     
  11. paul december macrumors newbie

    Joined:
    Feb 3, 2009
    #11
    very annoying bug, ready to sell this computer!

    The first keystroke failure is the worst bug I have ever seen in a computer, precisely because it appears randomly, sometimes it does it after two seconds, sometimes after five, ten, thirty. I have had problems typing passwords, and it obliges me to correct my typing, wasting minutes, hours of time. I am ready to sell this computer if Mac doesn't fix this bug. It has caused severe problems in many applications. It reminds me of the horrible PCs, that only respond to mouse and key commands after ten clicks, is that what intel has brought to us!?! are we doomed?
    P.
     
  12. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #12
    I have also had this problem occur while in tiger and a couple of months into leopard. After a couple of updates from apple which supposedly addressed the issue from different angles, it seems to have gone away mostly but not entirely. It still occurs but less frequently...but there is a noticeable delay when i start typing the first character.

    I also switched from using a bluetooth mouse to a wired one through usb. I am not sure if it had anything to do with it.
     
  13. mongrol macrumors regular

    Joined:
    Jul 16, 2007
    #13
    This was fixed completely for me by the firmware update that had keyboard patches in it.
     
  14. rhyx macrumors 6502

    Joined:
    Jan 15, 2008
    #14
    I think my first keystroke wakes up the computer from idle.
     
  15. z2000000 macrumors newbie

    Joined:
    Feb 12, 2008
    #15
    How I solved the problem

    Here is how my issue was resolved:

    I have apple care (first big plus-- you always get good treatment from apple) so I called numerous times, had a product specialist assigned to me. I had his actual email and phone number-- was able to bypass the queues-- nice.

    The product specialist had me go in to my local apple retailer and they installed not one, but two new keyboards. Problem remained.

    Next I had not two, but three logic boards installed. (the guy at the store just rolled his eyes because the logic board is so expensive he wondered why they didn't just ship me a new machine-- but he made a killing installing new logic boards for me so he was fine with it all. Unfortunately, problem persisted.

    Finally, I told my product specialist I thought it was time apple ponied up to the bar and sent me a new machine, which they agreed to do, and made it reasonably painless to do.

    So, after all the firmware, all the hardware, and all the software updates, I needed a new machine to solve the problem. Since I got a new MBP from apple the problem has not occurred once. I do notice that the problem seemed to start after I switched to leopard from the version of Tiger I was running, and as an experiment it may be worth running Tiger without any updates for a while to see if it runs without the hyper annoying elp! issue.

    Maybe you have apple care. Now is the time to work it.

    Good luck.
     
  16. Richard Whipple macrumors newbie

    Joined:
    Mar 14, 2010
    #16
    Missing first keystroke

    Had this problem for awhile until I got in the habit of waking my computer up with the keyboard and not the mouse. Problem solved for me.
     
  17. z2000000 macrumors newbie

    Joined:
    Feb 12, 2008
    #17
    re: missing first keystroke

    Sorry to hear about your problem. I am still using my replacement MBP with no issues to report. I have upgraded to snow leopard with no problems either. After trying every fix apple could come up with there were no solutions but to get a new MBP via apple care.

    Are you running snow leopard?
     
  18. mongrol macrumors regular

    Joined:
    Jul 16, 2007
    #18
    Holy necro posting. This issue was addressed in a firmware update over a year ago.
     
  19. MarkH356 macrumors newbie

    Joined:
    Jun 23, 2011
    #19
    The Firmware fix doesn't work. It cures the problem for about a month and then back it comes. Unfortunately you can't reinstall the firmware a second time to try and cure it again (it notices you already have the firmware installed and quits).
     
  20. Salukipilot4590 macrumors 6502

    Salukipilot4590

    Joined:
    Mar 17, 2009
    Location:
    Los Angeles, CA
    #20
    I've been getting this problem lately myself.
     

Share This Page