Not responding to keyboard commands on startup (flashing folder) and other problems

Discussion in 'Mac Basics and Help' started by jamalexandrou, Jun 7, 2014.

  1. jamalexandrou macrumors newbie

    Joined:
    Apr 19, 2011
    #1
    My trusty old Imac had a hard day yesterday.

    First we had a Flashing folder with a question mark on startup, so I restarted held down R and was able to run disk utilities and got a report back telling me the HDD was fine and dandy. I repaired disk permissions and restarted. No joy - Startup was now hanging on the apple logo/spinning wheel.

    Next I thought I'd try Target Disk Mode and mount my Imac HDD onto my MBP and run Disk Warrior as I have had a lot of success in the past in these situations. My MBP would just freeze up anytime It mounted the Imac HDD and the Imac HDD would need to be reset via the power button to get the MBP to even see that its there.

    Eventually I found out somewhere online that I could use a piece of software called disk arbitrator (https://github.com/aburgh/Disk-Arbitrator) Which would essentially stop MBP from mounting the Imac HDD but allow Disk warrior to see it, YEAH!

    Except That Disk Warrior doesnt like repairing a drive that has a newer version of OSX on it (Imac HDD pretty sure had Mavericks before it failed and MBP Lion) So I Upgraded the Mabook to Mavericks and got ready to finally save my Imac just as it started getting really uncooperative.

    The situation now is that the Imac will startup and hang on the flashing Folder Symbol. It doesnt respond correctly to any startup keyboard commands - Ill give you a rundown

    Holding T gives me target disk mode but It refuses to be seen on any other system (I tried MBP and an old macbook)

    Holding "option" or "alt" just gives me the mouse arrow on screen which I can freely move all around the nice grey sceen, but nothing else

    Holding R or command R doesnt seem to do anything

    I tried creating a Mavericks boot USB but holding C on startup doesnt help anythign either

    The last thing to say is the noise coming from my imac since IT became more uncooperative last night. It doesn't sound to my ear like a terrible clunk or click which would tell me the harddrive is now dead - but Its more like a chugachugachuga and after a minute or two of that ir sounds fine again .

    Anyway - any insight or help - If the harddrive is corrupted I feel like all I need to do is mount it and run disk warrior on it and I might be able to save it - I just cant seem to get it to...

    I am working to the limits of my knowledge on all this stuff too so please point out any missing info I can provide

    Imac Is probably 2007/8 - 2.8Ghz, 1tb harddrive (this is from memory)
    MBP is Processor 2.53 GHz Intel Core i5, 4 GB 1067 MHz DDR3,
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It sounds like you have a bad hard drive there. If it is a mechanical failure, it is not likely a utility like Disk Warrior will be able to help.

    You want to hold the option key when trying to boot to that Mavs installer though.

    If there is data you want on that drive, I would not try to reinstall the OS as that will make things worse. If it is important data, I would remove the drive and replace it then ship the drive off to a company that specializes in this sort of thing. It will not be cheap though.
     

Share This Page