Not resuming playback after calls...

Discussion in 'iPhone' started by Mobile923, Jul 30, 2008.

  1. Mobile923 macrumors 6502

    Joined:
    Sep 20, 2007
    Location:
    New York, NY
    #1
    Compared to my first gen iPhone, my 3G fails 3 out of 5 times to resume iPod playback after ending calls.

    anyone else?
     
  2. elbirth macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #2
    I've actually only received 1 call so far when I was listening to music and it worked just fine... didn't know there was any issue in this not working though, would be interested to hear other experiences
     
  3. Sonicjay macrumors 6502a

    Sonicjay

    Joined:
    Jan 1, 2008
  4. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #4
    Do you know if there is a dependence on if you end the call or the other party does?
     
  5. Mobile923 thread starter macrumors 6502

    Joined:
    Sep 20, 2007
    Location:
    New York, NY
    #5
    you know... good question. now that i think about it, i think its when i end the call
     
  6. atomicblastkarl macrumors newbie

    Joined:
    Jul 8, 2008
    #6
    It has resumed every single time that I have taken a call. I'm always listening to music, and I frequently get/make calls.
     
  7. elbirth macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #7

    fwiw, the one time so far that I've gotten a call while listening to music, I ended the call and it resumed normally
     
  8. Rigsby macrumors regular

    Joined:
    Sep 30, 2007
    #8
    I had a similar 'problem' with both my 1st gen and current 3G phone.

    I actually think it's a difference in the way some networks handle calls when terminated. What I noticed was that if I ended the call, music resumed. When the other party ended the call music would resume if the call was from a mobile phone or some switchboards, but not if it was an 'ordinary' home phone.

    I assumed it was something to do with some networks/phones/switchboards transmitting a 'call ended' signal that the iPhone could pick up on and, therefore, resume playing. Of course, it was complicated because, often, you both go to hang up at the same time and if they beat you to it you'd often click the headset and merely pause the resumed music before it started.
     
  9. Megalobyte macrumors 6502a

    Joined:
    Dec 30, 2007
    Location:
    Florida
    #9
    Same problem here, on my gen 1, music always resumed when the call ended, regardless of how, on my 3g, it never does. Hopefully this will be addressed in the update.

    Still, as long as I continue to average about 1.2 Mbps on 3G, I am prepared to overlook things like this... :)
     
  10. Rigsby macrumors regular

    Joined:
    Sep 30, 2007
    #10
    Ha, I'm getting 1.7 to 1.8...

    Off topic, but wanted to gloat!
     
  11. Megalobyte macrumors 6502a

    Joined:
    Dec 30, 2007
    Location:
    Florida
    #11
    Gloat away, but, my gloat's bigger, :p got several results today well over 2 Mbps, one was 2.2+ Mbps. :)
     
  12. Mobile923 thread starter macrumors 6502

    Joined:
    Sep 20, 2007
    Location:
    New York, NY
    #12
    Okay, i figured this much before 2.1:

    It's only when i'm on my bluetooth...

    When I end a call by pressing "End Call" on the iPhone's screen, the music would resume playback for a split second and then stop.

    When I end a call by pressing the button on my bluetooth, the music would resume as normal.

    now AFTER 2.1, it doesnt matter which button I use to end the call, 3 out of 5 times, the music resumes playback for that split second before stopping completely.
     

Share This Page