Not seeing Missed Messages in Mail app

Discussion in 'iOS 8' started by iphonefreak450, Aug 3, 2015.

  1. iphonefreak450 macrumors regular

    Joined:
    Dec 14, 2014
    #1
    I have an iPhone 5S running iOS 8.3 and I just started using the native Mail app on iOS 8.
    I am using Gmail messages to receive mails from this iOS mail app.
    However, I am not seeing the number of missed messages like the one from the below image.
    http://cdn3.tekrevue.com/wp-content/uploads/2014/07/disable-mail-notification-badge-ios-1a.jpg

    Another issue, I set the Mail app notification sound as Boing from the Sounds menu and I am not getting that either. The sound switch which on the side of the phone, is set to mute so the phone is just set to Vibrate when receiving calls, which I want it to do.

    Why I am not getting the number of missed messages and plus the sound whenever a message arrives?
    The Mail app is added under the Notification settings as well, plus, from the sound setting, I added the sond as Boing. But still no sounds heard as I emailed myself a Gmail message from my PC and no sounds heard from my phone. I am logged on with my Gmail account all the time on my phone.

    So all I want my phone to do, is when I get a new email message on my iPhone, I want to hear the notification sound (which is set under Sounds/Mail) but its not doing that. Can someone explain how to do this?

    Please help.

    Thanks
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Do you have any unread messages in your inbox--the badge shows the number of unread emails in your inbox basically.

    As for sound, all notification sounds are controlled by the switch on the side of the phone, so if you set it to silent/vibrate, that's what will apply to calls as well as app notification sounds, which is why you aren't hearing the notification sounds.
     
  3. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #3
    No, but I will test it.
    Is there any way to have my incoming calls to vibrate only, and mail notifications to sound?
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    You can leave the side switch enabled (basically not set to silent/vibrate) and then change your ringtone to a silent one (you might need to find a silent ringtone that you can use) and make sure that vibrate on ring is enabled in the sound settings as well--that way it should vibrate when you get a call but not make any sounds, and then still make sounds for notifications from apps (and also vibrate for them, typically).
     
  5. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #5
    Under Sounds settings, I cannot find the Silent options. Is there anywhere I can go to check it?
    Can you post print screens?

    I do not want to download any third party ringtones.

    I want my incoming calls to be silent only, no sounds or tones. But only enable sound notifications under the mail app.
    Please explain this.

    Thanks
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    I don't believe a silent option exists you'd need to create or get a silent ringtone on your own and set that as your ringtone for calls.
     
  7. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #7
    Ok, the new mail sound worked. But one problem with that, is that it only seems to work when I open up the mail app and refresh the Inbox manually.

    What I really want it to do, is have that new mail notification sound even when my phone is locked. Which is locked all the time for security purposes of course.

    For this to work, do I need the Mail app to be opened all the time because I tend to just close it by swiping the app upwards to get rid of it.

    I just wish the mail notification sound option would activate even if the phone is locked via the lock screen.
     
  8. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #8
    No need to wish for such a feature. Mail notification sounds DO play when the phone is locked. (any notification sound really)
     
  9. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #9
    So what else I have to check as far as settings go in order to have this done?
    The sound switch slider from the side of the phone is ON.
    Under Notifications/Mail, I have sound set to Boing.
    However, for security reasons, I have Do Not Show on Lock Screen to Enabled - Does this matter?
     
  10. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #10
    Having do not show on lock screen does not matter at all. I also don't show on lock screen, that's just a visual thing and not sound related.
     
  11. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #11
    Well, issue solved...I had the Fetch Mail settings to set to manual instead of every 15 minutes...
    Anyways guys, thanks a lot for the suggestions and quick responses.
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    Yeah, that would do it.
     
  13. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #13
    Are you saying that even with lock screen notifications disabled for Mail you still get a sound notification for new mail arriving? That doesn't seem to make that much sense given that you'd get an audible alert but then not see anything on the screen to correspond to it.
     
  14. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #14
    Yes I'm saying even with lock screen notifications disabled for email I still get the audio. The two aren't tied. The lock screen notification is just a visual to see. It makes sense. I don't want my lock screen flooded with notifications but still want an audio cue for when I get an email.
     
  15. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #15
    Quite odd (and not how I would expect it to work given that feeling an alert but not seeing what it is isn't really part of a typical user experience). On my part, when I have lock screen notifications disabled, I don't get anything for them at all, as if there wasn't a notification at all, as I would expect to be the case. I'd have a lot of audio/vibrate alerts from a lot of different apps if that wasn't the case.
     
  16. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #16
    The only option I have enabled for email notifications is sound and badges. (See image but ignore the "vibrate only" because that's just temp because in testing the tone bug I'm stuck with no audio for email until it's fixed)

    All the other options are just visual so you also see who the email is from. Not sure why you think it's odd. You'll still get the audio cue with visual notifications turned off. The only thing that turns off the audio is to set it to vibrate only (like mine is stuck at until a new build) and or switch the silent switch on the side of the phone.
     

    Attached Files:

  17. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #17
    When I close the Mail app by swiping up, does the notifications still would work?
    Or does the Mail app need to be open all the time?

    The Do Not Show on Lock Screen mode is for privacy reasons as some phones do provide message details even when the phone is locked. Same thing with Android phones. It shows you the missed phone number details, and some message details. But you do get the sound only.
     
  18. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #18
    Yes notifications will still work even when closed from inside the app switcher.

    iOS will still fetch your mail at whatever set fetch time you set in the mail settings regardless of if mail is open/running in the background.
     
  19. iphonefreak450 thread starter macrumors regular

    Joined:
    Dec 14, 2014
    #19
    Again, you guys are great for the quick responses. Thanks again.

    I really did not need the notifications features set, but I had to now because I am waiting for a very urgent email. After this, I will remove these settings.
     

Share This Page