not sure if this is an issue with router or iphone

Discussion in 'iPhone' started by fleeper, Aug 14, 2008.

  1. fleeper macrumors 6502

    Joined:
    Jul 30, 2008
    #1
    I have to reset my router (power off) before my iphone will connect to my wifi. If I use it in wifi mode, it will keep the connection, but if I leave the house or something, it will "see" the connection but not be able to connect unless I reset my router.

    Anyone else have this issue?

    fleeper :apple:
     
  2. chanatown macrumors member

    Joined:
    Aug 17, 2008
    #2
    I had a lot of issues with WiFi, but they seem to have improved since updating to 2.0.1. Did you upgrade? Some other things to consider are: brand of router, encryption level, wireless-g, etc.
     
  3. fleeper thread starter macrumors 6502

    Joined:
    Jul 30, 2008
    #3
    I have a belkin router and my laptops do not have any trouble connecting. There is no WEP on the router at this time. And yes I have upgraded to 2.0.1.

    he phone wills ee the router but it will tell me it cannot connect. After I power cycle my router everything is fine. Kind of a pain.
     
  4. BobboZR2 macrumors regular

    Joined:
    Jul 3, 2008
    #4
    Did you make sure to update your router to the lastest firmware? Try updating your router's firmware. Then, go into your iPhone and select: General > Reset > Reset Network Settings. After all that, try connecting to your network. The iPhone will connect to it as if it was connecting to it for the first time.

    Hopefully this will work for ya.
     
  5. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #5
    The only other thing is to reset your router to factory, then set it up again.
     
  6. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #6
    Did you mean you upgraded to 2.0.2?

    It's strange that it's not connecting even with no encryption. I had issues connecting to a friend's Belkin router that was using WEP. She recently changed to WPA and now I have no issues connecting.
     

Share This Page