Not sure what is dead or dying [GPU, HD or PSU?]

Discussion in 'Mac Pro' started by Wardenski, Jan 22, 2012.

  1. Wardenski, Jan 22, 2012
    Last edited: Jan 25, 2012

    Wardenski macrumors 6502

    Joined:
    Jan 22, 2012
    #1
    Greetings

    I was playing starcraft II yesterday, when strange black lines and purple bits appeared on screen. The computer crashed. This was using a 8800GT in a 2008 Mac Pro with the most recent version of Snow Leopard but also an unflashed 5870 Toxic (PC only) card inactive in the background and an inactive soundcard.

    I restarted and all was fine yesterday until I played SC, restarted and was ok all night (did not play SC). Today, the same thing happenened but just after a few mins of startup. After resart, I got stuck at the fan wheel during load up but there were no graphic artifacts.

    I managed to resart into windows without any problems but it seems that my 5870 has stopped working (though I forgot to plug back in the displayport connector to the card initially so it may be a driver issue). Anyway, I removed the 5870 from slot 2 and cleaned everything.

    I tried to start in OS X again, which as mentioned is on a separate HD but I got to the same place: crashed at fan wheel after a minute but there were no graphics artifacts.

    Today I have been using windows, using my 8800GT for hours and no problems apparently. Maybe, windows 7 is slightly less demanding on it at reduced visual effects settings than Mac OS X.

    Is it possible that my PCIe slot 2 has died? Though I am not sure why I can start up in Windows. Perhaps it could be my mac HD, but I am not sure why that would effect the 5870. I can here the HD do things upon start up and I can not hear anything irregular.

    I have not tried resetting PRAM or anything like that yet and I have not put the 8800GT in slot 2 yet. I need to get some work done while it works, just wondering if anyone has any ideas.:confused:

    Thanks
     
  2. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #2
    Update

    Hi put the 8800GT in slot 2. I get screen on startup so obviously slot 2 is not dead.

    Though I can still not start up in OSX but I can in Windows.

    I can't be bothered to retry with the 5870 at the moment but I am beginning to suspect that either the mac HD is dying or the 5870 has died whilst inactive and has screwed up something important software OSX wise.

    If the 5870 is dead and the 8800GT OK....
    and if the 3.5 year old OS X HD is dead and the 7 year old Bootcamp HD is OK....

    Then I can conclude that they don't make them like they used to.

    I will try resetting PRAM later. Not sure if SMC reset applies with these symptoms.
     
  3. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #3
    Update2

    Reset PRAM: no joy
    Boot in Safe Mode: Progress bar got half way before vanishing, then got the loading fan on its own, crashed about a minute later (i.e. same as before)
    Boot from CD: CD seems to load, get kernal panic eventually

    All of this with the 8800GT.

    I am now in bootcamp (separate HD) with 8800GT working fine. Debating whether a new HD is required or if the 8800GT really is dying but somehow is able to live in Windows 7.
     
  4. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #4
    Not sure until you reseat the 5870 and boot to OS X off the possibly dying HD.
    Figure out the HD issue first. Your in a better place than most as you have extra components to test with.
     
  5. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #5
    try playing a game in Windows or some other 3D app

    8800GTs can frequently be baked back to life (google it)

    BTW, the 5870 should work just fine in OSX 10.6.8 or 10.7+ with no flashing needed. It will NOT work over MDP but DVI port should work.

    BTW, how were you powering these cards?

    If you were using a splitter or tapping off the optical drives you may have ended up frying something that way.

    The 5870 will function in OSX, but will not show boot screens. It will run as a generic "Radeon 5000" using Radeonframebuffer. Flashing it would allow it to be a 5870 and use a specific frame buffer.
     
  6. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #6
    Unfortunately non of my games load in Win 7, apparently it is unworthy and does not meet the requirements. Moving the windows around does make it chug a bit and for a breif moment the screen appears blueish but the windows background does not dissappear.

    Beginning to wonder if its a power supply issue now though it does not explain why I can boot in windows and not in OSX with the same card.

    I use the splitters from the optic drive to prodive the 8-pin power connection to the 5870 in addition to the 6-pin from the motherboard. The other 6-pin connects to the 8800GT. I have never maxed these two cards out at once, the 8800GT was always inactive in windows and the 5870 inactive in OSX.

    Perhaps tomorrow I should take a look behind the optic drive. My optic drive does seem to work, it spins and reads as normal.

    As for the 5870, I am fairly certain it has always appeared as "display" in the sytem profiler.
     
  7. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #7
    It is possible there is a failure on the hard drive containing OS X install. Try and boot from the install disc, and if any joy leave installer and go to Utilities > Disk Utiolity and run Repair Disk.
     
  8. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #8
    ^ tried, got kernal panic

    Doing anything other than holding alt at start results in crash at start up.
     
  9. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #9
    Can't believe I did not try this before:

    I can access my Mac OSX disk from within windows and I am able to copy my work from it onto the bootcamp HD.
     
  10. Wardenski, Jan 22, 2012
    Last edited: Jan 22, 2012

    Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #10
    Ok...so I try and restart in OSX again after the above event..

    I get stuck at the loading fan icon screen again but I entered M on the keyboard and my passord corresponding to my user name. Behold, the HD loaded as per normal but the screen stayed at the loading fan screen.

    I then did ctrl-eject and pushed enter to shut it down and it did.

    So, does this mean my 8800GT is dying or are my drivers in OSX screwed up?

    I can still boot in Windows with 8800GT through DVI and access Mac HD.:confused:

    I will retry the 5870 tomorrow in OSX without 8800GT, I remember I have been using displayport with 5870 when in windows and will try DVI next time. Thanks for the replies so far. At least my mac is not dead.
     
  11. wafl iron macrumors regular

    Joined:
    Nov 16, 2007
    #11
    im surprised your 8800gt has lasted this long.

    its dead dude

    bake it or throw it away
     
  12. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #12
    There is no evidence on the Windows side that it is dying, no artifacts so far and startup is fairly quick. Performance is sluggish presumably because I have a 1920x1200 monitor, the 8800GT ran Windows 7 fine with my old monitor which is only 1280x1024.

    The 5870 does not work in OSX, I just tried but I have not tried it on its own in windows yet (I forgot). Bit annoying if its dead since I still need to play Crysis 2.

    I do not want to bake the 8800GT unless its a last resort, I was hoping it would last until the 7xxx becomes available for Macs.
     
  13. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #13
    Including cmmd-s for single user mode?
    You can mount the file system and repair or prior to mounting the filesystem you can fsck the HD.
    Do you still see the progress bar at OS X boot? This could be directory issue if you still have yet to boot the Mac HD and the 8800 is just peachy in Win.
     
  14. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #14
    Tried single user, it loads the screen but I am not sure what those commands do.

    I exited the single user mode by entering exit.

    Thanks for suggestion, lots of text appeared but the screen froze but again, behind the stuck screen, the HD loaded up as per normal and I was able to enter my user name, password and shut down with ctrl-eject.

    I have now noticed in Windows 7, that I have no sleep option. There are reports of this having to do with GPU drivers but apparently mine are up to date. Very tempted to reinstall OSX and ressurect files with Time Machine backup disk and then reinstall bootcamp, I have no patience for BIOS and driver mumbo jumbo. My main HD is nearly full..so perhaps it is time for a new HD.

    There are similar reports elsewhere so I need to investigate this a bit more. I wonder if an initial hardware failure, perhaps in the HD has caused the file system to be corrupted suggesting that my HD is struggling to read data properly.
     
  15. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #15
    Without running some of the commands how are able to be in single user mode and verify that the HDD has mounted "per normal"? Conflicting info.
    What Mac Pro rev are you on? 2010 or older? If it is 2010 you can't boot from 10.6 retail disc so it could still be the HD, you just have no way to boot it yet.
     
  16. 321estrellas macrumors 6502

    321estrellas

    Joined:
    Sep 28, 2007
    #16
    I am a victim of a dead 8800GT. I baked it with success, but knowing it wasn't going to be a permanent solution, I went ahead and got another card anyway. It's unsettling running a computer with a card on a coma, knowing it'll die again at any time.

    You already have a PC 5870...if I were you, I would just use that to boot up OS X as per MacVidCards response. It'll run it better than the 8800GT anyway! (minus the boot screen etc)
     
  17. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #17
    Its a 2008 Mac Pro, 10.6.8.

    I shall try the fsck -y command tomorrow and will repeat it a few times, I did not realise that the command was the disk check.

    I take it I am looking for "disk X modified" if there are problems and "disk X OK" if it has been repaired properly.

    Not very familiar with the ASCII stuff.
     
  18. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #18
    It's Unix.
    ASCII refers to text encoding. :)
    It gives you the commands at prompt to use if you want to get to the filesystem.
    To fsck the file system needs to be unmounted.
    To mount (I Think, it says at prompt):
    "mount -f /"

    Then you can run this:
    "diskutil repairDisk /"

    Disk tools without the GUI.
     
  19. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #19
    Today I did this in the following order, I wrote some stuff down on paper but my writing sucks.

    Took out the power cord and left for 10 mins to reset SMC
    Reset PRAM with cmd-alt-p-r
    Removed logitech mouse

    Booted into single user mode cmd-s:

    Ran fsck after mounting, get Macintosh HD is OK, get same thing three times in row.

    So I exit single user mode and in the text that follows I get these sentences which stand out to me:

    Warning-jp.pentycomdriver.steermouse declares no kernal dependencies
    USBF: 472.246 IOUSBInterface[0xb7c4400]:Joinpmtree could not find device
    Waiting for window server before finishing bluetooth setup

    At this point I still see the bluetooth sentence as the last thing that appears but my HD behaves as if I have reached the login screen. I can log in and shut down the computer with ctrl-eject but I still only see the text screen.

    I try booting up as normal holding cmd-v, I get the following sentences that stand out to me:

    Warning-jp.pentycomdriver.steermouse declares no kernal dependencies
    DMOS has carried
    NTFS <cant remember> 3.4 [Flash: R/W]
    NTFS volume name bootcamp, v3.1

    The volume name sentence is the last thing I see before my screen locks up but again, I can still login and shutdown using keyboard.

    So I try mount-f and get

    root_device on/ (hfs,local, read only, journaled)
    devgs on/dw (defs, local, nobrowse)

    So I try diskutil repairdisk and get

    unable to run becuase unable to use diskmanagement framework. Common reasons include, but are not limitied to, the DiskArbitrition framework being unavailable to being booted in SW mode

    I can still use the mouse and see the boot screen if I hold alt. Beginning to suspect that it may be a hard drive starting to fail though I am not sure why I can't start up from the Snowleopard CD. Perhaps I should use the one that came with my computer.
     
  20. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #20
    mount (space) -f (space) /

    After that you should be able to navigate through the file system.
     
  21. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #21
    Tried mount -f / get:

    -o force option not supported
     
  22. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #22
    You are right dude. Sorry.
    Just went through the motions as it had been a while.

    You want to enter as specified on the prompt:

    /sbin/mount -uw /

    But that won't help as Apple apparently has limited the ability of Disktools in single user mode. Strange as I remember being able to do this at one time.

    Maybe you can boot to DVD installer and not connect your display. Then use screen sharing on the headless box and run the Disk Utility tool to repair disk.

    Or better yet, ssh into the offending box and run it remotely.
    These are just ideas. You need to get that disk repaired as the directory is probably hosed.
     
  23. Wardenski, Jan 23, 2012
    Last edited: Jan 23, 2012

    Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #23
    I am tempted just to get a WD Caviar Black and remove the offending HD as I am not sure about this stuff.

    I tried mount -uw / and get

    no such directory

    Though this was after trying mount -f /

    Though I have my suspicions that other things have happened, I have not solved the mystery yet of the 5870 Toxic suddenly becominly inactive (or drivers inactive) in windows but that may have been catalysed by not connecting the GPU to the monitor.

    Also, Win 7 claims my 8800GT is in slot 2 but it is in slot 1, the drivers are screwed hence why I can not seem to play any games I would guess. It says locaton PCI bus 2, device 0, function 0. "Windows has stopped this device because it has reported problems (code 43)".
     
  24. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #24
    My Caviar Black has arrived but during the time I realised I won't be able to do a clean install since I can't boot the DVD.

    It all started with a graphical glitch in SCII originally, my guess at the moment is that the GPU or its VRAM got too hot and Mac OSX is simply too much for it now as similar things happened just browsing the guardian website. I did clean a fair amount of dust from it after this it has to be said, should have confessed that eariler:eek:.

    I can still use it in windows, but I always get code 43 and it operates without hardware acceleration but it works for browsing internet etc. I can still access and search my Mac HD too with no problems.

    I can apparently log in and shut down the computer normally using the keyboard but the white loading screen sticks without hearing anything nasty from the HD and I get no errors with fsck.

    Inclined to say its the 8800 now on its last legs but I have read reports elsewhere of fault logic boards causing similar issues but would I be able to start up at all or in safe mode if that were the case?
     
  25. Wardenski thread starter macrumors 6502

    Joined:
    Jan 22, 2012
    #25
    Solved, Dying 8800GT and HD

    Hi. Thought I would update.

    I replaced the 8800GT with a ATI 5770 and replaced the old Macintosh HD with the Caviar Black. Did a fresh reinstall and now using migration assistant. I am slightly fearful of a faulty PSU but for now I will enjoy life and get back to 10.6.8.

    I have not tested the 5870 Toxic yet though or put the soundcard back in place and won't do for a while until I need to play Crysis 2.

    I thought I would describe the initial issues I had today just for reference sake anyway so that someone might find it useful:

    I replaced 8800GT with 5770, boots up, but hung for a while at the loading screen with the apple logo, same as with 8800GT. After about a minute, the screen went blue and about another minute later the HD came back to life and the login screen appeared. Two steps further than the 8800GT.

    However, the keyboard and computer were barely responsive but the mouse was ok, obviously something else was wrong. I reset SMC and PRAM, same thing.

    I booted into Windows using the alt button. Windows 7 took longer to start up but once Windows 7 installed the 5770 drivers I restarted and booted back into windows. Windows 7 was fine, I was able to play Half Life 2 without any problems performance was good.

    I then removed the Mac HD and replaced it with the new one. Initially I had similar symptoms where it hung on the boot screen but eventually the CD did boot up this time. Did a clean install of snow leopard from the Snow Leopard retail disk.

    I noticed on the HD a lot of the exposed copper contacts were a different colour so I am slightly fearful of a faulty PSU at the moment. I need to check that the 5870 is still alive at some point in the future.

    Thanks for all the help and assistance
     

Share This Page