Not sure what i've done!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by andybloomfield, Nov 3, 2010.

  1. andybloomfield macrumors newbie

    Nov 3, 2010
    Hi everyone,
    I've searched the forum and couldn't find an answer to this issue and hope that someone can help me.

    I use iTunes to place playlists on my iPhone. Recently I created a playlist of some language course lessons which happily synced to my iPhone. I recently realised that when i created the playlist, iTunes hadn't listed the tracks in the correct order, ( ie track 1,2,3,4, etc) my fault, so this evening I edited the name of a number of the tracks, using the 'get info' function, from within the playlist. Feeling rather pleased with myself I connected my iPhone expecting the new playlist to replace the existing one of the same title but then noticed that the playlist was no longer listed on the music tab of my iPhone when viewed in iTunes. It was, however, listed as a playlist in the playlist pane in iTunes. I can play the playlist through the playlist pane but the tracks are no longer in my library.

    My question is, What exactly have I done and how can I return the contents of the playlist back into my library and ultimately sync the playlist on to my iPhone.

    I hope that this isn't too confusing a question and that someone can help.


  2. eastercat macrumors 68040


    Mar 3, 2008
    Try this:
    uncheck the playlist, then sync.
    Recheck the playlist, then sync.
  3. andybloomfield thread starter macrumors newbie

    Nov 3, 2010
    Thanks for your suggestion eastercat.

    After trying that and a few other unsuccessful tips I eventually discovered that iTunes had decided to import the disk in question as an audiobook rather than a series of songs. That's why they weren't in the library and the playlist that contained them wasn't seen by my iPhone.

    I deleted the playlist and the audiobook tracks from iTunes and then re-installed the CD. This time the tracks were imported as songs and synced no problem.

    Thanks again.


Share This Page