Notes App - Not Searchable

Discussion in 'Mac Apps and Mac App Store' started by worldomination, Dec 1, 2018.

  1. worldomination macrumors newbie

    Joined:
    Jun 28, 2014
    #1
    I love the Notes app. I love that I can add a note on one of my Apple devices and have it instantly appear on another.

    Lately, though, I haven't been able to search notes on my Mac. Searching notes on my iPhone works as expected.

    Frustrating.

    I've tried creating a new folder within Notes, moving my notes to it, and moving them back again.

    I've tried unchecking and re-checking Notes in iCloud.

    I've tried reindexing Notes by reindexing its folder through the Terminal...

    mdimport ~/Library/Containers/com.apple.Notes

    I've tried reindexing every other folder within Containers that is associated with Notes.

    I've tried reindexing my entire hard drive.

    No luck. I can't search my Notes.

    Suggestions, anyone?
     
  2. HDFan macrumors 65816

    Joined:
    Jun 30, 2007
    #2
    You didn't say how you are searching notes. Are you using the search box in notes, a spotlight search, a finder window search, ... What mac and what version of MacOS are you using? What version of IOS on your phone? Is the note you are searching for actually in your Mac notes?
     
  3. worldomination thread starter macrumors newbie

    Joined:
    Jun 28, 2014
    #3
    Searching within Notes (the search box), Spotlight, Finder search... nothing works.

    Mojave10.14.1. iOS 12.1. Yes, I can see a note in the Note sidebar and it's not searchable.
     

Share This Page