Notification issue just for messages

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by chuckm1020, Oct 6, 2016.

  1. chuckm1020 macrumors regular

    Joined:
    Aug 27, 2009
    #1
    im getting a weird issue regarding notifications just for messages. All other notifications are fine. I have an iPad and iphone and iMac. All signed in with the same Apple ID and signed in with the same Apple ID for iMessage. And all devices put on same settings for sending and receiving. When all my devices are idle. I am only receiving a sound and pop up notification on my iPhone. My Mac or iPad does not pop up with a notification. But for example if I wake my iPad, the notification will be there. Now if I'm using my iPad, it will alert me on my iPad, and not on my other devices for example. This just started happening. Usually when I get a message notification I receive them on all my devices. I've already missed a few messages. Because my Mac was on in my other room, it received the message notification. But my other devices did not alert me at all. Like I said, it is only for messages. Phone calls, emails, and all other notifications show up and alert me on all devices. I have restarted all devices. I have signed in and out of iMessage. I toggle pd notification on and off on all devices. And also, do not disturb is not activated with any device. Hopefully I explained the issue somewhat clearly. Any ideas? Thanks a lot
     
  2. tromboneaholic macrumors 65816

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #2
    I wish mine worked like that.

    It works like that for iPhone and iPad (only the active device gets a notification), but the Mac always gets a notification which is annoying to have my phone dinging in my pocket while my Mac does it too...
     
  3. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #3
    How funny. Yeah, that is exactly what I need. For my phone and Mac to get the notification at the same time. Here is the only thing I can think of. Im on the newest beta build for Sierra. Maybe they changed the way it worked. I just am hating when I leave my Mac on, then go to another room. And I don't get notified on my phone or watch, if I'm wearing it. Since it just gets the visual and audible notification on the Mac since it is on and not sleeping.
     
  4. tromboneaholic macrumors 65816

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #4
    Interesting that you're on the newest beta. I'm running the plain old public release of Sierra...

    I wonder if it would behave differently you turn off notifications on the Mac. I know you said you had toggled notifications, but have you tried leaving it off on the Mac? I don't know if you want them off all the time though...
     
  5. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #5
    I turned off handoff on all devices just to see. Makes no difference. But I then turned off notifications just on the Mac. Then I left my iPhone and iPad in sleep mode. The iMessage went to iPhone for the alert. Didn't alert me on my iPad at all. But when I unlocked the iPad, the notification is there. Just no audible or visual notification. Shouldn't it alert me on both devices since they were both locked?
     
  6. tromboneaholic macrumors 65816

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #6
    It does seem like both should alert you if locked. Maybe file a bug report about that specific issue. I keep my iPad on do not disturb all the time because I just use it for browsing the web and playing games. I don't like notifications interrupting me on it.

    I understand different people want to use it differently, but I think Apple could be a little more clear about what the expected behaviors are so we know how to modify them for our needs.
     

Share This Page