notifications when using airplay with 4.2

Discussion in 'iPhone' started by jas1973, Nov 7, 2010.

  1. jas1973 macrumors 6502

    Joined:
    Sep 10, 2010
    #1
    anyone else notice when using airplay from your iphone all your notifications get sent through what ever device you are streaming it to?

    so far low battery, text, and e mail notifications play through the airplay device. The phone rings on your iphone and shuts off what ever you are streaming. but all other notifications disrupt your music streaming with what ever tone the notification is set to. i guess i could live with this but when you pause your music your notifications still get sent to the airplay device. so if you pause the music and shut off your stereo speakers or whatever you are streaming it on, you will not receive your notifications unless you remember to manually witch airplay to "iphone"

    this only happens when you remain connected to your home net work. if you leave the building and disconnect from your wifi network it defaults back to your iphone. But if you stay with in your network you have to remember to manually switch airplay to iphone or you will miss your notifications..

    i think this is a bit of a nuisance. and i also hate having music i am streaming interrupted with text and e mail notification tones. especially if anyone uses those new annoying long text tones lol. unless there is a setting im unaware of i need to adjust.
     
  2. jas1973 thread starter macrumors 6502

    Joined:
    Sep 10, 2010
  3. J.C macrumors 6502

    Joined:
    Nov 12, 2008
    #3
    Yes. It's ****ing annoying.
     
  4. eagleglen macrumors 6502a

    eagleglen

    Joined:
    Oct 2, 2009
    Location:
    San Diego, CA
    #4
    I haven't tried this with Airplay, but if you are just playing music on your iPhone, you can flip the ring/silent switch and the notification sounds stop. Meanwhile, the music can still be heard. I think this will solve your problem.
     
  5. jas1973 thread starter macrumors 6502

    Joined:
    Sep 10, 2010
    #5
    then you do not get any notifications at all. yes that helps it not interrupt your music but you do not hear your phone calls or any other notifications.

    this is a major bug if you ask me
     
  6. DevDav macrumors newbie

    Joined:
    Jul 25, 2011
    #6
    Airplay needs a Privacy or Don't interrupt mode

    Although placing the phone on vibrate definately helps matters:

    There are times (IE streaming music at a party, in the man-cave, watching a movie etc) that I don't even want a phone call to interrupt me.

    I know you can hit ignore and airplay will usually pick back up where it left off but it seems there are enough use cases that Apple could give us some options on an Airplay settings page to cover them...

    I shouldn't complain about bleeding edge technology but I hope Apple product management reads these forums :D
     

Share This Page