Now my Al imac has died.

Discussion in 'iMac' started by C-vez, Nov 5, 2007.

  1. C-vez macrumors newbie

    Joined:
    Nov 5, 2007
    #1
    I have had my Al imac for 30 days. In that time, it has taken me several attempts to boot back on if I shut down or restart. I have installed leopard since then. Now, it will not come back on at all. I wonder if anyone else has had the problem?

    I have had several macs, I own three as of this moment. Never had that problem before.

    BTW, I never experienced the "freeze".
     
  2. djc6 macrumors 6502

    Joined:
    Aug 11, 2007
    Location:
    Cleveland, OH
    #2
    I would call apple IMMEDIATELY if its truely been 30 days. There is a 30 day window where if a hardware failure manifests itself, they will consider the unit DOA (Dead on Arrival) and they will replace the unit instead of repairing it.
     
  3. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #3
    Which iMac did you buy?
     
  4. C-vez thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #4
    iMac 20in 2.4ghz

    Got it taken care of yesterday. I had put in a Ken. 1GB module pc 5300 667and the CPU was rejecting it. I upgraded my mac mini the same day with the same brand, no problems.

    I called Apple about the memory issue. Of course they said I should be upgrading with their memory. $150.00 is ridiculous for 1g of ram.

    Anyway, I am returning the module today and will replace. I will let you know the outcome.
     

Share This Page