Now unable to Scan with HP Printer

Discussion in 'OS X Mavericks (10.9)' started by nicefellow, Nov 19, 2013.

  1. nicefellow macrumors newbie

    Joined:
    Mar 18, 2011
    #1
    Since I updated to Mavericks OS X 10.9, I am unable to scan from my HP F380 printer.

    Apple/HP state that scanning now runs from OS X via ‘Scan’ page in Printers & Scanners form System Preferences window.See:

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03967522

    Have followed instructions given at HP website above, to the letter. Little ‘Scanner’ window opens, but then get error message saying:

    Failed to open a session on the device.

    This seems buggy. Does any kind soul know of a solution?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try removing the scanner from the list in the pref pane then readd it so the drivers get reinstalled. Then open Image Capture from the /Applications folder and see if it finds the scanner and can scan from it.
     
  3. macmacgoose macrumors regular

    Joined:
    Mar 15, 2012
    #3
    The only way I've managed to get the scanner working on Mavericks is by going to the HP website and downloading the software/driver for OSX 10.7. I used to use the printer on a Snow Leopard machine and it worked no problem. Since getting Mavericks, I could only print. So last resort using older software and works fine as far as I can tell. The App Store is telling me now to update the drivers but I'm assuming it'll just revert me back to the newest Mavericks one that won't work. So I'm ignoring that update. Drove me crazy as I had to always use my PC when I needed to scan.
     
  4. travman macrumors newbie

    Joined:
    Mar 6, 2014
    #4
    n00b question

    I tried to install the driver for 10.7 but Mavericks disallowed it, stating that the file was for 10.7 and before only.

    Any ideas on how to get it to install on 10.9?
     
  5. macmacgoose macrumors regular

    Joined:
    Mar 15, 2012
    #5
    I just accidentally installed the latest Apple HP Software Update (2.16.1). So I had to remove it and reinstall the 10.7 driver from the HP website once again. Which printer are you using? I have the HP LaserJet Pro M1210 series and it allowed me to install the 10.7 driver. It popped up a firmware install too, but I don't think I need that, as I already have an update firmware for my device.
     

Share This Page