NSOutlineView custom colors

Discussion in 'Mac Programming' started by ranguvar, Oct 27, 2009.

  1. ranguvar macrumors 6502

    Sep 18, 2009
    Hey ho,
    I got two questions:

    1) How can I customize NSOutlineView's row highlight colors (the dark blue gradient when the NSOutlineView is focused, and the lighter blue gradient when it is unfocused)? I tried various methods I found over the net, but none worked (which might be because I use Apple's ImageAndTextCell). Basically I would like to have a somewhat lighter gradient.

    2) In my app, I use a split view, with a source list on one side and a table view on the other side. How can I prevent the views from getting unfocused (and then changing their colors to the 'unfocused' look) when I click in the other view? An example is the Finder: when you select an item like 'Downloads' and then click back in the list of files, the highlight gradient behind 'Downloads' doesn't change. But in iTunes, when you select 'Music' and then an album, the gradient does change.

    I realize those questions partly overlap, but I'm stuck with both.
    Thanks for any help!

    EDIT: I feel like posting way to much in this section, but I somehow cannot post to the Cocoa-dev request list. Whenever I try and send a request, it sends me a mail saying I was not allowed to post. I then contact the list's owner, but he / she / it doesn't answer. Any help on that matter?
  2. chown33 macrumors 604

    Aug 9, 2009
    on the Western Slopes, with E. A. Poe
    If you mean Apple's cocoa-dev mailing-list, it only accepts posts from subscribers. It checks the email address of the post, and if that email address isn't subscribed, the post is essentially dropped in the bit-bucket.


    Subscribing involves responding to an email triggered by a request to subscribe.
  3. ranguvar thread starter macrumors 6502

    Sep 18, 2009
    Yeah, I already am subscribed. Apparently, the problem was that I had subscribed using '@gmail' but the submissions were sent from '@googlemail'. :rolleyes:
    It seems to work now.

Share This Page