NTFS-3G problem..searched & found no answers

Discussion in 'Mac Basics and Help' started by MetalStryker, Apr 2, 2009.

  1. MetalStryker macrumors newbie

    Joined:
    Apr 2, 2009
    #1
    I installed MacFuse and then Installed NTFS-3G.

    I unmounted the external Harddrive that is in NTFS.

    I Typed in the terminal command line that was given to me in the CNET video of how to install NTFS-3G. I got an error in terminal that the command was unknown.

    Now when i try to access my files that I had on the external it shows nothing. Its a 500 gig drive, and i had alot of avi files on it. And its saying that there is only 188 gigs available... but i cant see any of the files on the drive and i still cant write to the drive.

    I tried uninstalling ntfs-3g and it gives me errors and i uninstalled macfuse. still nothing.

    I reinstalled everything again and i just cant access my files anymore.. I even tried using the external on my windows machine and it sees a mass storage device but i cant even access it from the windows machine anymore.

    ANYHELP... please. Thank you.
     
  2. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #2
    You're not giving us a lot of information. I'm not familiar with the CNET video describing how to install NTFS-3g ... what exactly did you type? What was the the error?

    Where did you get MacFUSE from? Was it here? - http://code.google.com/p/macfuse This gives you a file called MacFUSE-2.0.3,2.dmg. Double clicking this mounts it and you see a pkg file that you install with another double click.

    And where did you get NTFS-3g from? Was it here? - http://macntfs-3g.blogspot.com/ - you should have got a file called NTFS-3G_2009.2.1u1-ublio-catacombae.dmg. This is a disk image containing a pkg file that you double click to install NTFS-3g.

    In neither of these do you have to do anything in Terminal to access the external drive.

    If you've tried to view your external drive on a Windows machine and see nothing, then something you've done has done something to the drive ... unfortunately, without more information, I don't think anyone can help.
     
  3. MetalStryker thread starter macrumors newbie

    Joined:
    Apr 2, 2009
    #3
    Yes.. I got both of those files from the sites that you gave links to. And I installed them after downloading.

    http://www.youtube.com/watch?v=fxTBBj6g164

    thats the video that I watched. In the video it told me to type this into terminal:

    sudo ln-s/Systems/Library/Filesystems/fusefs.fs/mount_fusefs/usr/bin/mount_fusefs

    it came back saying it couldnt do it. and then all of a sudden the files stopped showing in the external drives folder, yet, like i said the space on the drive is still taken up.

    If you need anymore information than that just ask... im new to troublshooting macs so i dont know exactly what info ya guys may need to help me, so just let me know.

    Thanks again.
     
  4. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #4
    This:
    is incorrect syntax. It should be:
    Note, it's System, not Systems, and there are spaces there.

    However, fusefs.fs doesn't exist in /System/Library/Filesystems/ - in the latest MacFUSE releases it's in /Library/Filesystems/fusefs.fs/Support/

    But that video is almost a year old ... I'm guessing the MacFUSE developers realized that /System shouldn't be written to since Apple updates can overwrite files in there. Also, I don't have to do any Terminal commands to mount and view NTFS drives.

    I don't see how any of this could have affected your NTFS drive, unless there was some problem that coincided with your installation. Syntax errors in commands wouldn't affect anything since the OS won't actually do anything if the command is incorrect.

    How did you unmount the external drive?
     
  5. John Jacob macrumors 6502a

    John Jacob

    Joined:
    Feb 11, 2003
    Location:
    Columbia, MD
    #5
    Don't you need another space? As in:

    Code:
    sudo ln -s /Systems/Library/Filesystems/fusefs.fs/mount_fusefs /usr/bin/mount_fusefs
    Edit: Of course, if the command wouldn't have worked anyway because the file locations have changed, then this won't help.
     
  6. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #6
    I don't know what you mean :D
     

Share This Page