Resolved NTFS Mounter External Hard Drive Problem (SOLVED!)

Discussion in 'Mac Basics and Help' started by Diogones, Jun 4, 2011.

  1. Diogones, Jun 4, 2011
    Last edited: Nov 19, 2011

    Diogones macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #1
    I have a 500GB Seagate external USB hard drive that is formatted as NTFS. I recently decided to attach it to my Mac so I could manipulate some of the files on it. Once I realized that Macs by default do not write to NTFS drives, I downloaded and installed NTFS Mounter. At first, everything went as expected. I mounted the drive with NTFS Mounter, and I was able to write to the drive. After I ejected the drive, however, I began to have problems.

    I plugged the drive into my Windows machine, and it warned me that I had to format the drive. This struck me as odd, because I hadn't formatted the drive while using the Mac. I ejected the drive from Windows, and plugged it back into the Mac. The drive appeared as usual, but when I opened it, the Finder window was completely blank. I checked the Get Info box, and the drive still has my data on it, as the current occupied space matched what I had put on it. However, the permissions was set back to read only. Even after I mounted the drive with NTFS Mounter, the permissions were still read only, and no data was visible in the Finder window. I know the data is on there, but the drive appears as though it's completely blank. Since it's an external USB drive, I can't fix drive errors or repair permissions with Disk Utility. Similarly, I can't run CKHDSK on Windows because Windows won't mount the drive, claiming that it has to be formatted first.

    I fear the worst: that the drive has somehow become corrupted, and the format is no longer readable by either Windows or Mac. I may have to reformat the hard drive, and that in itself won't be so bad, but is there anyway that I can recover the data on it before I do so? As stated previously, I know it is on there, I just simply can't access it. I'm completely stumped, and any help would be appreciated!
     
  2. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #2
    I finally found a workable solution to this hard drive issue. I inserted the drive into my Mac, and ran Disk Utility. The drive didn't mount, but it was still accessible and visible through the utility. I ran the "Repair Disk" command and it repaired the damaged sectors. The Disk Utility claimed that the repairs couldn't be completed after it had run the repair, so I just launched the repair again. After the second time, everything completed successfully, and the device mounts and unmounts correctly now. Just to be sure, I attached the drive to my Windows comp, and it came up without a hitch!


    I'm removing NTFS Mounter; I just don't want to run the risk that my drive will get damaged again.
     
  3. CCC-SWEETS macrumors newbie

    Joined:
    Jul 9, 2011
    #3
    Same Problem

    Hi,

    I have exactly the same problem. I have Seagate External Hard Drive, which I have been using with Windows computer, but recently I bought a MAC computer, I downloaded NTFS mounter, it was working at first but after I rebooted the computer, my hard drive does not work on neither of my computers.

    I read your solution, but it didn't really make sense... You said you cannot use disk utility on Mac with your Seagate hard drive at first, but in the solution, you said you used disk utility to solve the problem. How did you get to use the disk utility on your hard drive? Did you do something different?

    I tried using check disk on windows and disk utility on Mac, but neither of them work on my hard drive now. I am so desperate...

    I have been searching for solutions of the similar problems, but strangely I only found your post. I would think this would happen to many Seagate and NTFS mounter users, but I don't see any other post on similar problems.

    Could you please let me know how you solved the problem a little more in detail?

    Thank you!
     
  4. Diogones, Jul 11, 2011
    Last edited: Jul 11, 2011

    Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #4
    Hey there CCC!

    I'm sorry if my sad hard drive story seemed a bit obtuse, so let me clear the air a little bit, as it were.

    After I used NTFS mounter, my external was visible in the Mac's Disk Utility, but every option in the First Aid tab was greyed out. However, after I ejected it, and reinserted it back into the Mac, I was able to use the First Aid options after all. What I did was run the "Disk Repair" command, and the utility went about repairing the hard drive. After that was completed, I removed it and reinserted it back into the Windows machine, and thankfully, Windows recognized it as a valid drive, and it also mounted properly on the Mac desktop.

    My advice to you would be to try once more to use the Mac's Disk Utility, and run a drive repair. You should see the drive visible in the Disk Utility's left hand column where drives are listed. Select yours and give it a shot. If that doesn't work, let me know, and I can give you the text command you can enter into Terminal.app.

    Yet another idea would would be to use a Linux live disc to access your files on the drive, back them up to your computer's hard drive, and then re-format the drive as NTFS in Windows so it is usable again. On the other hand, if you wish to avoid this problem again, you could always format it as FAT32, so that Mac and Winboxes could read and write to it without issue.

    Creating a live Linux disc is very simple. If you have a blank CD or DVD (the latter may be required if the version of Linux is too big to fit on a CD) - preferably the RW kind - then you are almost set. Simply go to Ubuntu.com, or another similar, easy to use Linux version (I personally recommend Puppy, because it is small, light-weight and fast) and download the smallest version you can find. This will help to cut back on download time and CD/DVD size requirements. Usually the download will be a disc image, or .iso. If you don't have a blank CD or DVD to spare, then you can always create a bootable live Linux version on a USB stick, but that's outside the scope of my response, and you can always find out that technique elsewhere.

    What you will do next depends on whether or not you are using Windows or a Mac. If you are using Windows, simply right-click the .iso file, and from the contextual menu that appears, select the open with option, and choose Windows Disc Image Burner. Once the Image Burner is done burning the iso to the CD or DVD you have selected from the Image Burner menu, simply reboot, and from the BIOS or boot menu select your CD/DVD drive as first in boot priority (it's usually set as the default, but it doesn't hurt to check anyway).

    If you are using a Mac, first mount the .iso. insert the blank CD/DVD, open Disk Utility, and select the .iso from the left-hand disc list. From the DU menu, select New -> Disk Image. Choose to format the disk image as DVD/CD Master, name the disk image, and click Save. When the .cdr file is finished, select it from the list in DU, and click burn. Once it is burned, you can select the disc as the startup disk in System Preferences. Otherwise, reboot the Mac while pressing and holding C.

    Once you have made the disc, and have successfully booted into the Linux environment, insert your external hard drive. Linux will read it, because it has built-in NTFS read/write support, and you will be able to get your data off of the drive. Ensure that you place it safely in your main OS partition, and not the temporary Linux partition! Once you have done that, you can either reformat the drive in Linux, or you can restart your computer and eject the disc.

    I know this probably all seems like a LOT of work, and you may consider your data not worth all this trouble. In that case, just go the old-fashioned route and reformat the drive. That's a simple and direct, if somewhat brutal, solution. If I didn't elaborate enough for you on a particular detail, or if I lost you somewhere along the way, there are plenty of fantastic guides to creating a bootable live Linux disc on the Internet, and a quick Google search should help you out on that front. Remember, you want a "Live" version, not an Install version, for the simple fact that a live version creates a temporary environment for you to work in, which is expunged once you reboot the comp. An Install version will of course install a version of Linux on the machine.

    You are certainly right; it is strange that there are not more posts about NTFS issues with the Mac, but then again I suppose most Mac users don't consider it a huge issue. Still, it is an oversight on Apple's part not to include integrated NTFS read/write support out of the box. It would certainly help avoid situations such as these!

    So, to recap: try to repair the external using the Mac's Disk Utility, and if any repair options are available, use them all. Failing that, we can try going from the command line. If that doesn't work, access your data via a live Linux version, and then reformat the drive. Good luck!
     
  5. CCC-SWEETS macrumors newbie

    Joined:
    Jul 9, 2011
    #5
    Thanks

    Hi Diogones,

    Thanks for very kind detailed reply!

    I actually tried a lot of things on that day and found a solution.

    I asked the same questions at other sites and everybody recommended me to get data recovery software, get back ups and format the drive. But I had close to 500GB of stuff in the hard drive, so I wanted to find quicker solution (a lot of them were backed up, but I use DVDs for back up so I didn't wanna have to go through all the DVDs to collect all the data again, which would take forever).

    (I tried connecting and disconnecting the hard drive a few times, but my Mac didn't let me use Disk Utility repair.)

    And also my hard drive corrupted like nothing has happened, I didn't drop it, I didn't format it, I just used a software called NTFS mounter with it and it corrupted, so I couldn't help but think there must be a solution to recover the hard drive itself, instead of recovering each file in the hard drive.

    And the best solution was a free software called TESTDISK. http://www.cgsecurity.org/wiki/TestDisk_Download

    This software solved my problem in like 10 minutes. I highly recommend this software if you have any other problem with you hard drive next time (hopefully there will be no next time though).

    Neither Mac nor Windows recognized my hard drive, but after going through a quick process with TEST DISK, my hard drive came back with all the data in it in 10 minutes. I didn't have to go through recovering each file, I didn't lose anything either.

    I also emailed a person who is responsible for NTFS mounter, but haven't heard back from the person. NTFS mounter is now in my black list of softwares.

    Anyway, I will keep your recommendations for the future. Thanks again!!
     
  6. Fernie61 macrumors newbie

    Joined:
    Jul 14, 2011
    #6
    Help!

    Hey!
    The exact thing is happening to me now...

    DiskUtility showed all options grayed out, no matter how many times I reconnected my hard drive.

    After reading everything you guys wrote I downloaded TESTDISK, and after struggling a bit, I got it to start analyzing my hard drive. I don't know if I did that wrong, because you said it only took you 10 minutes and for me it was going at a rate of 3% each hour!
    Anyway, I suppose it was using my computer to back up, because i ran out of space in my internal hard drive, which forced me to cancel the operation...

    Am I doing it wrong?

    Could you please explain to me what you did? (Sorry, I'm completely ignorant in these matters) :(

    Here's a link to a post I made on another forum, with a further explanation of my problem:

    http://www.mac-forums.com/forums/os-x-operating-system/244005-help-external-hard-drive-mounting-went-wrong.html#post1265625
     
  7. CCC-SWEETS macrumors newbie

    Joined:
    Jul 9, 2011
    #7
    Deep Search

    Hi Fernie61,

    Sorry you are having the same problem.

    I think the reason why it's taking so long is because you chose to do "deeper seach". When the TESTDISK tries to find the drive, or files, at first it does quick search and shows you the drive name and then tells you if you still don't see the drive/files you are looking to fix, you should do "deeper search".

    Fortunately I found everything I needed after quick search, so I didn't have to do deeper search. So, it only took like 10 min for me.

    You see your drive there on TESTDISK, right? Then don't go to deeper search and when you see your drive there, just select "write" and see if what you need is going to be recovered. If you don't get all you need, you can go back to TESTDISK and try to find them again.

    When I was doing this, TESTDISK didn't show "write" selection. So I was upset, but I went back a few process by using "Q" key, and tried the process again, and the "write" selection showed up.

    http://members.iinet.net.au/~herman546/p21.html
    http://maketecheasier.com/recover-data-and-partitions-for-free-with-testdisk/2011/05/19

    These sites kind of explains how to use it. Of course we all are in different situations, but it helped.

    After you've done "write" process, it'll tell you it's finished, so you should just leave the hard drive connected to your PC, and re-start your PC. Your PC will start fixing the drive when it re-boots on a light blue screen. For me this process only took like 5 minutes. And everything was back to normal again.

    I hope this helps! Good luck!!!
     
  8. Fernie61 macrumors newbie

    Joined:
    Jul 14, 2011
    #8
    One more question..

    Hi! Thanks fir your prompt reply, it was very helpful. I now tried to use testDisk with my windows xp netbook and after a few tries i got the 'write' option. But when I restarted, nothin happened and when I try to open my hrd drive it now says "invalid format", which is a change but apparently still a problem! Any ideas?
    Thanks again, I really appreciate your help!
     
  9. CCC-SWEETS macrumors newbie

    Joined:
    Jul 9, 2011
    #9
    Check Disk?

    When I was struggling, I tried to do "check disk" of Windows. You know, when you right-click your hard drive, you press "properties" - "tools" - "check now". When I tried to do that, Usually it starts right away or it says something like "check disk cannot be operated now and it'll check the disk when you re-boot", but when I did that this time, the window of check disk just disappeared. So, I thought it does not work on my corrupted hard drive either. So I tried TESTDISK software. And after I did TESTDISK and rebooted, it did things kind of similar to what "windows check disk" would do. Blue screen and fixing errors. So, I was a little confused if it was done by "windows check disk" or TESTDISK software. But because "check disk" just disappeared and seemed not working, so I came to a conclusion it was done by TESTDISK.

    But I went back to "how to" instructions of TESTDISK, it does not talk anything about fixing errors on blue screen when rebooting. So, I am not sure, but maybe the fixing process was done by "windows check disk".....

    I am really not sure. But maybe you should try using "check disk", too.

    I did "check disk" first, which didn't work, and then did TESTDISK, rebooted my PC, and it started fixing.

    Now you've done TESTDISK, maybe you'll be able to do "check disk"... I don't know... Give it a try... Good luck.
     
  10. archerfish macrumors newbie

    Joined:
    Aug 12, 2011
    #10
    ntfs mounter

    Hello Diogones,

    I have the same problem here except that my drive is working fine in windows. Some files are inaccessible in mac but are running in windows. Disk Utility options are grayed out in my external drive no matter how many times I reconnected my hdd.

    The first time I used NTFS MOUNTER my external hdd is working fine (samsung) and the next day a friend of mine copied some files from me and it also worked (kingmax) but when I inserted seagate, NTFS MOUNTER just unmounted and mounted the drive but the seagate drive is still in "read only". The following day, some files in my samsung hdd is inaccessible with/without NTFS MOUNTER.

    I don't think I need to repair it, I just need to have access to my drive since I can access it in windows but I would like to try the text command in Terminal.

    OFF TOPIC:

    Does LINUX LIVE that you were saying can run in mac? I apologize for my ignorance and I'm really curious.

    Thanks
     
  11. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #11
    Hey there archerfish,

    I'm sorry for the delayed reply: I've been out of town for a couple of weeks. Hopefully you have reached a resolution to your problem. If not, then I do have some suggestions for you.

    I don't know how large your drive is, but you don't have too much data, then I would suggest the simple albeit brutally direct approach, and simply move everything off of your drive in Windows, reformat it (either as FAT or NTFS) and check the disk for errors, and then return your data to it.

    Also, please remove NTFS Mounter, for as both me and CCC-SWEETS have painfully learned, it is simply not completely stable. Instead, download and install the free MacFUSE and then install NTFS-3G a free read-write driver for Mac that is much more reliable than NTFS Mounter.

    If you have a HUGE amount of data, or if you just simply can't be bothered with reformatting your drive, then I would first download the two utilities I mentioned, and then try to connect your external back to the Mac.


    As for your Linux question, yes there are plenty of distros that you can experiment with, and will work with a Mac and its EFI. If you are asking me if you can run in from within OS X, then yes, you can run it as you would any other OS: with virtualization. You could install Oracle's free virtualization software, and then run the live version inside of that. If you are really interested in knowing more about that, then please feel free to PM me about it. I don't want to clutter up a thread with an entirely different topic.

    Hooray for CCC-SWEETS! I'm glad that you figured out how to recover your data. Of course, I had heard of TESTDISK, but I simply didn't include it in my post to you. But you can't remember everything! :)
     
  12. trevor2522, Sep 1, 2011
    Last edited: Sep 2, 2011

    trevor2522 macrumors member

    Joined:
    Sep 1, 2011
    #12
    I have a Maxtor 1TB external hard drive pre-formatted and loaded with data from Windows xp. Now I want to write to it from a current Macbook. I installed Macfuse and NTFS-3G (the free one). When I try to mount the Maxtor I get this error message ...

    NTFS-3G

    NTFS-3G could not mount /dev/disk1s1 at /Volumes/Local Disk because the following problem occurred:

    /Library/Filesystems/fusefs.fs/Support/fusefs.kext failed to load - (libkern/kext) link error; check the system/kernel logs for errors or try kextutil(8). The MacFUSE file system is not available (71).

    This kid made a video about it but when I 'Get Info' from the Maxtor there is no Universal Identifier Code to copy like in his machine. Since installing Macfuse and NTFS-3G I can't mount the Maxtor. If there's no software solution all I can do is buy another external drive formatted for Mac. It's ridiculous that Apple haven't addressed the problem of writing to NTFS drives with their machines.

    http://www.youtube.com/watch?v=O_nc0NTw8ds
     
  13. trevor2522, Sep 2, 2011
    Last edited: Sep 2, 2011

    trevor2522 macrumors member

    Joined:
    Sep 1, 2011
    #13
    MacFuse Incompatibility with 2011 Macbooks

    There is a possible work-around described here ...

    http://thenakedman.wordpress.com/2011/06/23/macfuse-encfs-snow-leopard-and-macbook-pro-2011/

    My Macbook Pro 13" was purchased in May 2011, so falls into the 'MacFuse won't run' category.

    I removed Macfuse and NTFS-3G and re-installed according to the site above, without the Xcode (I'm not paying $99 to join up) or Homebrew. I did manage to get the UUID this time under Get Info.

    The video instructions http://www.youtube.com/watch?v=O_nc0NTw8ds STILL didn't help. The Maxtor external hard drive remains unmountable and unreadable. How do I undo the Terminal script entered from the video to reinstate my Mac as it was? Video was made in 2010 but there seem to be problems with 2011 Macbooks like mine. Thanks for any advice.
     
  14. archerfish macrumors newbie

    Joined:
    Aug 12, 2011
    #14
    Thanks

    Hello Diogones,

    I already installed TUXERA NTFS and it's working fine. I can't reformat my drive since I have nowhere to copy it (400GB) so I just tried TUXERA NTFS. I noticed that some files (strange) that are accessible to mac is not accessible to windows (remember that previously I mentioned that some files became inaccessible to mac but are running in windows after NTFS MOUNTER).

    I don't know what happened since I didn't do anything but just install TUXERA NTFS. I experimented by making a copy of the inaccessible file then deleting the original file. When I opened it in windows, it's running normally.

    I'll try your suggestion one of these days. THANKS A LOT!

    OFF TOPIC

    How do I PM you? I apologize again for my ignorance, this is the first forum I joined and I still don't know the basics.
     
  15. trevor2522 macrumors member

    Joined:
    Sep 1, 2011
    #15
    Whew!

    Solved my NTFS write problem by running chkdsk /i (External Hard Drive) on a PC. There were a few file issues which it corrected.

    Then uninstalled Tuxera to save $20 in 14 days' time. Installed MacFuse and NTFS-3G (Jan 2011 version). Works for free! Save yourself the cost of a new hard drive!
     
  16. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #16
    Glad you got it all figured it out trevor. :) Yes, when in doubt, always always always check the drive, either with Windows, Linux, or Mac; more than once if you can, just to be sure. It is certainly an easy step to overlook in examining more advanced troubleshooting techniques.

    I've never used TUXERA NTFS archerfish, but if it works for you, then I say full speed ahead! As far as sending someone a PM, it is simple really. Just select the individual from the forum and follow them to their profile page. There should be an option to PM from there.
     
  17. 2Sirius4me macrumors newbie

    Joined:
    Nov 11, 2011
    #17
    try this

    I downloaded NTFS For Mac OS X. The trial is for 10 days. It worked immediately with no apparent conflicts or other problems. After playing with it using PC external drives I couldn't previously mount or write to, I decided it was worth the $20- for the activated software even though I could have done what I needed to do within the 10 days. Why? Because I figured after days of trying to get this to work, and reading all your honorable replies to the original query, that this was worth having Just In Case and because I want to keep using the NTFS external drives to save back up copies of photos etc. Incidentally I am running Lion OS 10.7.2 on an iMac.
    Hope this helps.
     
  18. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #18
    Thanks for your input, 2Sirus4me, but the version I used was not a trial version. I know that there is a paid version of NTFS-3G but that is only for more speed and stability improvements. You can use the free version indefinitely, which is what I have installed. Are you sure it is the same program?
     
  19. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #19
    Any reason folks don't use ExFAT? OSX 10.6 and newer, plus XP (with Microsoft patch) through Win7 support it.
     
  20. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #20
    That's a very good question, blueroom, and using exFAT (i.e. FAT-64 bit) is certainly another option. For example, exFAT supports much bigger file size transfers than FAT32, so if that's all users wish for their external hard drive, then it makes sense to use it, as full read and write operations for exFAT are supported with Mac 10.6 right out of the box.

    The main arguements I could see against using exFAT instead of NTFS are these:

    1.) SL supports exFAT, but what about 10.5 or earlier? Some users might still have their PPC Macs, with their respective OSes on them, so exFAT support may be limited, if it even exists for those platforms.

    2.) NTFS supports NT compression and encryption; not something most people are bound to use, but they are useful file features that bear mention.

    3.) NTFS supports NT journaling, which is sort of like the HFS+ format Macs use. I'm not sure if exFAT supports journaling or not, but it is certainly helpful for disk and file repair.

    There are probably other features with both NTFS and exFAT that I'm missing completely, but the exFAT filesystem is a great idea for those looking for a cross-platform format that is more robust than FAT32, without all the hassle of dealing with NTFS write operations.
     
  21. zihzahey macrumors newbie

    Joined:
    Oct 14, 2009
    Location:
    Egypt
    #21
    Repair

    Hi all
    i faced all the above for 1 terrabyte with 2 partions one is ntfs and mac hfs.
    I used repair for man times and before open it eject this partion from diskutility then open it , working
    thanks
     

Share This Page