NTFS volume (BC) will not mount without NTFS-3G.. Technical..

Discussion in 'macOS' started by Thrash911, Feb 6, 2009.

  1. Thrash911 macrumors 6502

    Thrash911

    Joined:
    Sep 14, 2006
    Location:
    Randers, DK
    #1
    Hello people, ;)

    Irritating problem.. I previously used NTFS-3G to write to my NTFS (Boot Camp) volume. Now, I would like to can it, and just use Apple's internal read-only NTFS stuff.. But the drive refuses to mount, if I disable or remove NTFS-3G.. If I try to mount it manually in Disk Utility, it just says "The disk could not be mounted. Try running First Aid".. I tried that, and it did not work (as expected).

    I have tried to create an empty file with TOUCH command in the root of my NTFS drive, called "ntfs-readonly". I have also tried to put that file in a directory called ".NTFS-3G" in the root. According to this site, it should tell NTFS-3G to mount that drive with Apples read-only driver. But this failed to work as well - getting the same error as above, when trying to mount it manually.

    An interresting thing is, that when NTFS-3G is running, the format of the NTFS drive reads "Windows NT Filesystem (NTFS-3G)" - fine, that sounds logical. BUT.. When NTFS-3G is disabled, the format reads "MS-DOS (FAT32)".. Which, of course, is not true.

    Is Apples NTFS mounter broken on my system, maybe? If so, how can I fix that?

    I recall, that I removed NTFS-3G and Mac Fuse manually some time ago, using this site as guidance. That involved deleting the files it was using. I was very careful, but MAYBE I deleted one or more files, that Apples internal NTFS read-only driver needed... :eek:

    Can somebody perhaps assist me in some way? ;) What can I try (apart from re-installing OS X using my Time Machine backup..)..?

    EDIT:
    Holy crap, I figured it out!! I found the wonderful program Pacifist which allows the user to install parts of the OS. I opened the install disc, and searched for "ntfs". A critical file was missing in my system, so I extracted it to the right location. Then I rebooted (not sure if that was neccesary), and voila!! It mounts!! And the format of the drive reads correctly "Windows NT File System (NTFS)".. YAY!! That's how we learn not to delete important system files.. :eek:
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar

Share This Page