Num Lock? in nano in the Terminal

Discussion in 'macOS Sierra (10.12)' started by Mike Richardson, Oct 6, 2016.

  1. Mike Richardson, Oct 6, 2016
    Last edited: Oct 6, 2016

    Mike Richardson macrumors newbie

    Mike Richardson

    Joined:
    Apr 23, 2010
    Location:
    The circle effect on my avatar is non-consensual
    #1
    You have to do this using a real, full size keyboard, that has a separate numeric keypad area, such as a Tactile Pro.

    1. Open a Terminal window.
    2. Type "nano" and press enter.
    3. Press any number on the separate numeric keypad area, such as "0" (zero).
    4. You will not have the expected behavior. (I cannot easily compare 10.12 to 10.11/10.10, only to 10.9, so I don't know if 10.12 is actually the first version with this problem)

    This is on a MacPro5,1 with a brand new macOS "mack-oss" Sierra / Mac OS X 10.12.0 installation.
     
  2. Mike Richardson thread starter macrumors newbie

    Mike Richardson

    Joined:
    Apr 23, 2010
    Location:
    The circle effect on my avatar is non-consensual
    #2
    This also happens in vim. What is the deal here? Why are these text editing programs assuming that Num Lock is not activated?
     
  3. HenryAZ, Oct 9, 2016
    Last edited: Oct 9, 2016

    HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #3
    I am not seeing the same behavior, in vim at least. I am using a daskeyboard, and numbers from the numeric keypad (all the characters from the numeric keypad, in fact) insert as expected within vim. Perhaps it is a Matias keyboard issue?

    ETA, another thought, perhaps the terminal emulations have changed under Sierra. Have you tried different terminal settings? I've always used the good old-fashioned vt100 for my Terminal windows.
     

Share This Page