Number not showing up on others' caller ID

Discussion in 'iPhone' started by c073186, Sep 3, 2008.

  1. c073186 macrumors 6502a

    Nov 2, 2007
    I just got an iPhone with a new phone number and whenever I call people; their caller ID says Unknown or Restricted or something similar, even though they have me listed in their Contacts list. Why is this and how can I fix it?
  2. 12GA macrumors member

    Mar 17, 2008
    Upstate NY
    On your iPhone go to Settings ---> Phone ----> Show My Caller ID ----> ON
  3. c073186 thread starter macrumors 6502a

    Nov 2, 2007
    Okay now I officially feel stupid. Thanks.
  4. cellocello macrumors 68000


    Jul 31, 2008
    Toronto, ON
  5. Small White Car macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    I find this setting to be worded very poorly.

    It seems to me that MY caller ID is on my phone. You know, it's the thing that tells me who's calling me? That's my caller ID showing their phone number. (Or so I'd think.)

    But apparently not. It seems that my caller ID is what's on other people's phones. And their caller ID is on my phone.

    Seems backwards, but whatever. I just think they could explain that a little better in the setting. Maybe call it "reveal my number to caller ID" or something like that. As it is, I thought that 'off' meant "don't show me who is calling me."
  6. BergerFan macrumors 68020


    Mar 6, 2008
    Mos Eisley
    I guess it should be worded: "Withhold Number". Simple, and everyone would get it.
  7. chrismac00 macrumors 6502a

    Dec 17, 2007
    Yeah I turned this setting off so it wouldn't show my caller id, which i thought was just the name not the number and I wondered why my friends didn't pick up. It showed up as anonymous. :p They should change it.
  8. wackymacky macrumors 68000


    Sep 20, 2007
    38°39′20″N 27°13′10″W

    The other few mobiles I have had all say something like caller ID off/on, all it does is tell your carrier how to handle your outgoing calls.

    Personally I felt that "Show my Caller ID" was self explanatory.

    And who would want to turn off the incoming number display anyhow?

Share This Page