Numbers '08 Hangs on any operation

Discussion in 'Mac Apps and Mac App Store' started by isgoed, Dec 31, 2007.

  1. isgoed macrumors 6502

    Joined:
    Jun 5, 2003
    #1
    I just installed iWork '08 and found out that Numbers hangs whenever I want to open or create a graph. Also if I select text it hangs (spinning beach ball forever). It is completely unusable. Restarting my computer does not work. I have Numbers version 1.0.1. I am running on an intel 1.66 Ghz core duo mac mini with OS X 10.5.1. Does anyone else have that problem/Solution?
     
  2. isgoed thread starter macrumors 6502

    Joined:
    Jun 5, 2003
    #2
    Problem solved

    Ok I spent some time on this one but I managed to fix it. If people experience really unexplainable problems you may check if all users on the computer have the same problem. In my case I found out that If I logged in as another user the problem was gone. If all fails you may have to do a complete reinstall. The actual solution I had may be interesting for other people too, because it resets the invisible system preferences.

    The funny thing was that now I also solved another bug I had with the unit converter widget.

    Both crashed occured when code was run in the libicucore.A.dylib dynamic library. So I though that it was a fault in that library.

    The problem arose because My user account was imported from a powerbook G4. Also the invisible preference file ~/Library/Preferences/.GlobalPreference.plist was copied. Apparently that file caused issues on my mac mini. I removed it by using the terminal (I renamed (terminal mv command) the file to "GlobalPreference.plist" (without the dot) and moved it away.) The next time I launched Numbers it worked perfectly. I add an anonymoused copy of that file to this message for reference.
     

    Attached Files:

Share This Page