Numbers on El Capitan: dot instead of comma?

Discussion in 'Mac Apps and Mac App Store' started by MrFusion, Nov 8, 2015.

  1. MrFusion macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #1
    I want to format numeric values with a dot instead of a comma: 4.5 instead of 4,5.
    Normally you have to adjust the region settings in System Preferences to get this across all apps.
    This was the case for Numbers as well.

    But with El Capitan: Numbers is not using my custom format. Not even after rebooting.
    How can I force Numbers in El Capitan to use dots instead of commas for numeric values?
     
  2. flashy-cat macrumors regular

    flashy-cat

    Joined:
    Apr 8, 2007
    Location:
    UK
    #2
    God knows why the rest of Europe isn't standardised to using a decimal point anyways.
     
  3. MrFusion thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #3
    Probably the same reason why the US is stuck with imperial system instead of metric. Inertia and unwillingness to change. Occasionally it even results in a crashed mars lander.
     
  4. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #4
    I'm certainly not going to defend the US's refusal to go metric. It makes no sense to me.

    But your example is off the mark. Strictly speaking, it wasn't because imperial units were used. The orbiter (not lander) disintegrated because Lockheed's software sent data in imperial units to NASA's software, which was expecting metric values. The issue was a mismatch. Obviously there would have been no mismatch if Lockheed had produced metric data. But there would also have been no mismatch if NASA had been expecting imperial. It was a communications/management issue.

    This does nothing to solve your problem, I know.
     
  5. jerwin macrumors 65816

    Joined:
    Jun 13, 2015
    #5
    hmm?

    I switched my region to France, and Numbers 3.6 properly calculated =3/2 as 1,5
    switched it back to US, and the result is 1.5.

    So what's the issue here? How might we replicate this anomalous behavior that you're experiencing?
     
  6. MrFusion thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #6
    No idea. In system preferences the numbers are displayed as expected. I tried changing it a few times and restarting numbers but no dice. First time I am experiencing this odd behaviour.
     
  7. MrFusion thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe

Share This Page