Numeric Keypad does not work with Excel

Discussion in 'Mac Accessories' started by bluesrules, Mar 6, 2014.

  1. bluesrules macrumors newbie

    Joined:
    Aug 26, 2008
    #1
    I am using a MacBook Air with an Apple USB keyboard connected and the number pad stopped working with Excel. With all other applications it works. Help anyone?
     
  2. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #2
    Try hitting the Clear key on the number pad, while in Excel.
     
  3. bluesrules thread starter macrumors newbie

    Joined:
    Aug 26, 2008
  4. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    That's the strangest thing. My numeric keypad on the wired Apple keyboard works fine in Excel for me. It must be something you toggle on and off within Excel itself.
     
  5. bluesrules thread starter macrumors newbie

    Joined:
    Aug 26, 2008
    #5
    Yes, you are right, this is the strangest thing that has ever happened to me and it gets even worse, it used to work!!!

    It stopped working after I started messing around with the settings in the System Preferences.

    I have now turned everything back to the defaults and still no joy.

    I really hate this!!

    Anyway, thanks for the comment, if you can think of something will be appreciated!
     
  6. bluesrules thread starter macrumors newbie

    Joined:
    Aug 26, 2008
    #6
    Problem solved!!!

    So, finally I managed to solve this (Thank you Mark!!)

    Very simple:

    When in Excel hit the key Shift and Clear. Clear is the key that is above number 7 on the keypad

    This should solve the problem.

    Also, if you are looking for a Scroll Lock key hit Shift and F14

    Hope this can help someone else!!
     

Share This Page