Numerous Network Issues

Discussion in 'OS X Mavericks (10.9)' started by stulk, Aug 12, 2014.

  1. stulk macrumors newbie

    Joined:
    Aug 12, 2014
    #1
    I have a mid 2012 15" retina Macbook Pro running 10.9.4. I've had networking issues for a long time, possibly before I upgraded to 10.9. Hoping I can get some ideas on how to get it working like a fresh install, without re-installing.

    I can connect to my home LAN (wired & wifi), hotspots no problem. I can see some of my network devices (like Time Machine, or a PC or a Drobo), but only if I enter their ip address directly. This could be SSH, or just using the finder. My other Macs don't ever see this machine, and I don't automatically see my other machines under "devices" in the Finder like with my other macs.

    Another screwy issue is with Minecraft... i play together with my son a lot. I can host a game on a PC and connect to it, but only if I manually enter the IP address and port number.

    I have checked, re-checked, checked again the network settings in Network Preferences. It's on the right Subnet, has the right IP address, router, DNS entry. I have tried renaming the /Library/Preferences/SystemConfiguration when booted into the fresh install and then booting back into the primary, to eliminate any plist files in there that might be corrupt, but that didn't fix it.

    I did a clean install on a separate partition and I have no problems, so it isn't hardware. I am tempted to just reinstall, but would rather try and see if there is a configuration I can reset first.
     
  2. asriznet macrumors regular

    Joined:
    Dec 21, 2013
    Location:
    Singapore
    #2
    What happens when you click on Finder menu bar: Go -> Network on the affected mac? Are you able to see the other devices here?

    You might need to restart Bonjour
    I would probably do another backup and install OS X Mavericks over the system. It shouldn't delete your data or anything but if anything happens, you have a backup at least.
     
  3. stulk thread starter macrumors newbie

    Joined:
    Aug 12, 2014
    #3
    On the Finder->Go->Network, I did this before I tried restarting bonjour, and all I saw was my iMac, but it was showing up like a PC (the old-style monitor). I couldn't access it. No Drobo, no time machine, no other computers/devices.

    I restarted bonjour per your suggestion after. No change, other than the iMac disappeared from Network.

    Thanks for the suggestions. I'm going to try your other one of reinstalling over the existing system to see.

    ----------

    One other thing I noticed. I can connect to ip addresses, but not DNS names on the local network. for example, my Drobo IP address is 192.168.1.50 and it is named Drobo5N. On my fresh install I can telnet or ssh to drobo5n.local, but on my main install I get "node name nor servname provided, or not known"
     
  4. stulk thread starter macrumors newbie

    Joined:
    Aug 12, 2014
    #4
    Well, no-luck with the reinstall over the existing OS. Any other ideas? Appreciate the suggestions!
     
  5. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
  6. stulk thread starter macrumors newbie

    Joined:
    Aug 12, 2014
    #6
    Yes, file sharing was on, for both SMB and AFP.

    I installed the Yosemite Beta... problems solved :)

    Thanks for the help.
     

Share This Page